Keynote, Pages & Numbers - crashing

Discussion in 'macOS Catalina (10.15)' started by e555kx, Jun 6, 2019.

  1. e555kx macrumors newbie

    Joined:
    Jun 6, 2019
    #1
    Hi guys, I can't start any apps from iWork package: all crashing with an error:

    Crashed Thread: 1 Dispatch queue: com.apple.root.background-qos

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000018
    Exception Note: EXC_CORPSE_NOTIFY

    Termination Signal: Segmentation fault: 11
    Termination Reason: Namespace SIGNAL, Code 0xb
    Terminating Process: exc handler [2377]


    I reinstalled them from the Appstore with no luck. Anyone could make them running?
     
  2. adrianlondon macrumors 65816

    adrianlondon

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #2
    Working here. However, Pages did crash when I first tested it by just running it and opting to create a new, blank document.

    When I instead opened a pages document then it worked. And now, opening a new blank document is also working.

    I've just tested and ... Numbers and Keynote also crashed the first time (open new blank document) but worked the second and subsequent times.
     
  3. e555kx thread starter macrumors newbie

    Joined:
    Jun 6, 2019
    #3
    very nteresting, it keeps crashing on me. Maximum working for 5 seconds no matter what I do
     
  4. adrianlondon macrumors 65816

    adrianlondon

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #4
    Do you have any documents saved in iCloud? I don't use iCloud drive at all but if you do, that could be something to investigate.
     
  5. e555kx thread starter macrumors newbie

    Joined:
    Jun 6, 2019
    #5
    No, even when I try to open a locally stored document, it is still doing it unfortunately.
     
  6. adrianlondon macrumors 65816

    adrianlondon

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #6
    I'm out of ideas. Log a Feedback, attach the diag files and hope it's fixed in the next beta!
     
  7. jdliebs52711 macrumors newbie

    jdliebs52711

    Joined:
    Mar 14, 2018
    Location:
    South Riding, Virginia
    #7
    I'm having the same issue as you e555kx. I've deleted and reinstalled them several times and have both opened a saved document as well as try opening a blank document from the app first and crashes every time. Let me know if you figure it out at all.
     
  8. e555kx thread starter macrumors newbie

    Joined:
    Jun 6, 2019
    #8
    No luck yet. I guess we have to use a browser version till they fix it, hopefully in the next release. The funniest thing is that third party stuff is working fine, and Apple's native software not :)
     
  9. adrianlondon macrumors 65816

    adrianlondon

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #9
    I still can't replicate this. They all work for me, and I don't know why! :)

    Assuming you're sending the crash logs to Apple I'm sure it'll get fixed in time for the next beta. As you say, this is Apple's native software so it must get priority.
     
  10. ozhero macrumors newbie

    ozhero

    Joined:
    Sep 2, 2013
    Location:
    Tasmania, Australia
    #10
    All working for me also and I use iCloud Drive.
     
  11. jdliebs52711 macrumors newbie

    jdliebs52711

    Joined:
    Mar 14, 2018
    Location:
    South Riding, Virginia
    #11
    I hope it get's fixed soon. AS for now I was using Word but I didn't even think to use the browser version... ... :( thanks for the great suggestion for now!
     
  12. ozhero, Jun 7, 2019
    Last edited: Jun 7, 2019

    ozhero macrumors newbie

    ozhero

    Joined:
    Sep 2, 2013
    Location:
    Tasmania, Australia
    #12
    I've just installed Office 365 and that all seems to be working great. Except have a problem with OneDrive but going to get some sleep soon as it's 4:15am here, before I resolve the issue.

    I suspect it will be a security issue and don't want to fool with these with little sleep :)
    --- Post Merged, Jun 7, 2019 ---
    This is the problem I am having if any kind soul has already solved it.

    I can see the folder in finder so it has created it. But it is not syncing any files into it.

    Screen Shot 2019-06-08 at 4.19.41 am.png
     
  13. jdliebs52711 macrumors newbie

    jdliebs52711

    Joined:
    Mar 14, 2018
    Location:
    South Riding, Virginia
    #13
    yeah it seems from other forum posts on here that OneDrive is not working which is the another app i heavily rely on along with Pages.
     
  14. ozhero macrumors newbie

    ozhero

    Joined:
    Sep 2, 2013
    Location:
    Tasmania, Australia
    #14
    Thanks for letting me know. I'll have a go at it today and see if I can get it working. If so I will post a solution.

    This is my "test" boot anyway so no problems if it doesn't :)
     
  15. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #15
    Just out of curiosity - are you referring to iWork 09? ie Pages version 4.3?

    Or the new version that comes with Catalina?
     
  16. weup togo macrumors 6502

    Joined:
    May 6, 2016
    #16
    There is a very good chance that iWork will require app updates to fix this bug. If so, they might wait until later in the release cycle, so they can avoid multiple compatibility releases for one OS.

    OTOH it would be pretty insane to ship a “public” beta next month with these apps broken. We’ll see soon.
     
  17. e555kx thread starter macrumors newbie

    Joined:
    Jun 6, 2019
    #17
    I hope that's not the case. Web version isn't as good as the standalone app.

    I am very curious to find out why its working with some and doesn't work with others. I tried both in 2015 MacBook Pro and 2017 iMac.
     
  18. Stefdar macrumors newbie

    Stefdar

    Joined:
    Feb 4, 2012
    #18
    When you launch Numbers, Pages or Keynote and there is another program running that is using over 50% CPU cycles then they won't crash, or they will after a long time. If you launch iWork with no other program open or on an almost idle cpu state, it starts on 10%, then 15, then 25, then 80, and then it crashes.
     

Share This Page

17 June 6, 2019