Keys @ and " swapped on on Windows 7 via Boot Camp - help needed please!

Discussion in 'Windows, Linux & Others on the Mac' started by Garrod, Feb 19, 2012.

  1. Garrod macrumors regular

    Garrod

    Joined:
    Nov 13, 2008
    Location:
    UK
    #1
    I've tried tons of things to sort this out but to no avail and searching here and elsewhere hasn't helped. I've got a UK Apple Extended keyboard that I'm using on my 2011 27" iMac - they keyboard is the one from my old late 2006 iMac. My problem is that the @ and " keys (shift+2 and shift+', or AT and double quote) are the wrong way round. Also, several other keys don't work 'correctly'; for instance, the = sign on the numeric keypad doesn't do a thing and the tilde doesn't work (shift+the key to right of the left shift).

    I'm really stuck with this problem. It happened before and I changed it quite simply by messing around with the keyboard / language settings in Windows 7's control panel (64 bit Windows) but now? I messing with the settings changes nothing. The problem seems to happen the most after I've quit playing a Windows game (but that might just be coincidence as I only really boot into Windows to play games).

    Is there anyone that can suggest a solution to this? Incidentally, the volume, eject keys all work fine, as do the symbols such as £. I'm truly stuck and any help would be appreciated!
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    You need to go into the keyboard/ language setting in windows and add uk set it to default and remove u.s
     
  3. Garrod thread starter macrumors regular

    Garrod

    Joined:
    Nov 13, 2008
    Location:
    UK
    #3
    Thanks but I've done all that. There is only the one keyboard setting being used but it's as if Windows decides all on its own to swap the keys around to what I can only presume is a US keyboard.
     

Share This Page