Killed App Stays in Dock

Discussion in 'macOS' started by dandiggs, Dec 12, 2007.

  1. dandiggs macrumors newbie

    Joined:
    Jul 11, 2006
    #1
    Hi Everyone,
    Been running into this problem more frequently lately, but has been something I've battled since I got this MBP (CD 2.16). I can't seem to find any solutions, but maybe I'm not searching the right string.

    When I kill an unresponsive app, either via terminal or force quit, often times its icon will stay in the dock with an arrow (or LED in leopard) below it, as if it were still running. Of course, it isn't running, the process isn't listed in the Activity Monitor or in 'top' in Terminal. If you try to click the dock icon or reopen the application, nothing happens. The major headache is that my computer will refuse to cleanly restart or shutdown, it just hangs during the shutdown sequence.

    I've tried killing the dock, killing the Finder, 'sudo reboot' in Terminal - nothing seems to be able to fully kill the app or allow my to perform a clean restart... and it pains me to give the computer a hard restart.

    I recently performed a clean install of Leopard on a brand new 200gb internal HDD, hoping my problems in Tiger were a thing of the past, but I'm still running into this one... along with major memory leaks and crashes from Firefox. I'm beginning to fear that I may have hardware issues, but please tell me it ain't so. I've double, triple checked my RAM installation, it seems fine. Any thoughts???

    Sincerely,
    Frozen in time
     
  2. TBi macrumors 68030

    TBi

    Joined:
    Jul 26, 2005
    Location:
    Ireland
    #2
    Sounds like you have a hardware issue.

    Try booting the install CD and holding 'd' for diagnostics. I think that's right, it will say it on the CD.
     
  3. dandiggs thread starter macrumors newbie

    Joined:
    Jul 11, 2006
    #3
    Now didn't I just say, "Tell me it ain't so!" :p

    Thanks for the suggestion, I'll report my findings.
     
  4. lil'homunculus macrumors regular

    lil'homunculus

    Joined:
    Oct 30, 2007
    Location:
    vancouver, bc
    #4
    milk just poured out of my nose!:eek:
     
  5. dandiggs thread starter macrumors newbie

    Joined:
    Jul 11, 2006
    #5
    And I thought I was the one having problems! :p

    So, I ran the hardware test and no problems were detected. HOWEVER, although I had completely uninstalled all of the Digidesign Core Audio drivers, I physically disconnected my Digidesign mBox 2 from my MBP and haven't incurred any freezing or unkillable apps since. We're talking only a half hour of uptime so far, but considering I had two freezes already this morning, I'm thinking positive.

    If Digidesign is truly the root of all of my problems in OS X, I'm through with them. They consistently neglect to support OS X upgrades with any timeliness. And come on, you can't make your hardware and drivers compatible and relatively crash free?? Although I'll have to keep it around for ProTools sessions, I'll keep it unplugged otherwise.

    I'll keep this thread posted of my findings in life post-mBox. Here's hoping the problem is fixed either way.
     
  6. Blogger macrumors 6502

    Joined:
    Jul 18, 2002
    Location:
    Local
    #6
    Just as a FYI, I'm using a Metric Halo interface with no problems in Leopard.
     
  7. dandiggs thread starter macrumors newbie

    Joined:
    Jul 11, 2006
    #7
    Good to hear the Metric Halo is compatible - been wanting to check their interfaces out.

    Folks, I can say with confidence that the Mbox has been the root of all instability issues with Mac OS X, both in Tiger and Leopard. Two days since I disconnected, and not even as much as a hiccup. Really makes you appreciate the beauty of Leopard when you don't have incompatible hardware.

    To anyone out there with an Mbox 2 setup experiencing any kind of issues with their OS, disconnect it and see if your problems go away - it'll save you a load of time!
     

Share This Page