Kindle for Mac problem - anyone else?

Discussion in 'Mac Apps and Mac App Store' started by juliainor, May 11, 2010.

  1. juliainor macrumors member

    Joined:
    Sep 12, 2009
    #1
    I downloaded the Kindle for Mac software yesterday and purchased one book. It is showing up in my Archive section with a comment "Download failed, Try again." I have tried multiple times to download the book, but I keep getting error messages saying the book cannot be downloaded, try again. I went through their troubleshooting guide (which is very minimal) and nothing fixed it. I emailed Kindle C/S and they said it must be my firewall or anti-virus. I turned off the firewall, still didn't work. I don't run anti-virus software on my Mac. I've tried to call Kindle C/S since those weren't the problem, but haven't been able to get through yet.

    I've tried it on three different wireless networks and one wired network - fails on all. My internet access is totally normal otherwise; everything else is working and downloadig just fine. I'm exasperated.

    Has anyone else had trouble with downloading something to Kindle for Mac? I'm beginning to think it's a problem with the title on their end.

    If anyone has suggestions, I'd love to hear them.
     
  2. Fireproof! macrumors 6502a

    Fireproof!

    Joined:
    Dec 1, 2008
    Location:
    Frisco, TX
    #2
    Weird. I've used Kindle for iPhone, Mac, and iPad and it's worked flawlessly. I haven't purchased new books through each device, but I've been able to download books from my Amazon archive just fine.
     
  3. tomreese macrumors newbie

    Joined:
    May 22, 2010
    #3
    Kindle problem redux

    I had bought six books which I was happily reading in Kindle software under 10.6 on a MBP. Got a new MBP this week with solid state memory, 10.6.3, and used the convenient sych firewire connection to copy everything from the old to the new MBP. Everything worked perfectly on the new MBP to the last detail-except my Kindle books. When I first tried to read them I got a note telling me to remove them, which I did. Then I logged into my amazon account and downloaded them again. They all showed up in my book list, but when I try to open them, I keep getting a message that they 'can't be downloaded now, try later'. Internet connection is high speed FIOS. I pulled out all the Kindle software, reloaded the software, went back to my amazon account and downloaded the books again, but the 'can't download now' problem persists. Emailed amazon, but no reply so far. A relief to hear that the problem is out there, but when, how do we get a fix?. I should have been warned about an big brother at amazon/kindle by the incident where they decided to remove people's books, but I do like the kindle reader...
     
  4. tomreese macrumors newbie

    Joined:
    May 22, 2010
    #4
    more thoughts on kindle problem

    It occurred to me that my experience (see redux, above) eliminates firewalls and antivirus software as possible explanations for the 'can't download now' problem because I had no problems with the old MBP, made an exact duplicate of all my software onto a new MBP, and the problem immediately appeared. Networks, firewalls, antivirus all have to be identical between a system that worked perfectly and one with the 'can't download now' problem. Seems to me this pretty much locates the problem at amazon, possibly because they thought I was trying to get away with duplicating books?
     
  5. juliainor thread starter macrumors member

    Joined:
    Sep 12, 2009
    #5
    I finally gave up on this. I tried everything I could think of and everything Amazon suggested and nothing.

    Conversely, I installed Kindle for Windows on my Win7 desktop and the books downloaded immediately.

    I hope someone comes up with a solution at some point, because I sure would like to be able to have these particular titles on my Mac.
     
  6. tomreese macrumors newbie

    Joined:
    May 22, 2010
    #6
    kindle problem

    One last try was to 'buy' a free book from Amazon, which appeared on my book list in my Amazon account, and then downloaded 'successfully' when I asked it to. However, I can't see the new book in kindle on my MBP, though the others are there! Trashed all kindle files including "My Kindle Content" where books or their aliases are stored, reinstalled Kindle , went back to my Amazon account, and downloaded 'successfully' again. Restarted. Re-installed kindle, but still could not see the new book, and the ones I bought still 'can't download now'.

    Don't know what else to do...have to give up...Thanks for reassurance I have not overlooked anything!
     
  7. tomreese macrumors newbie

    Joined:
    May 22, 2010
    #7
    kindle problem solved

    Open Kindle software, go to Preferences, hit 'deregister' button. but not the 'remove content' button, hit the register button and fill in your amazon ID and PW, hit return, close pref. window, and now you can read your books...worked for me-hope it works for others....t
     
  8. bob5820 macrumors 6502a

    bob5820

    Joined:
    Jun 23, 2006
    Location:
    35°0′36″N 80°40′45″W (35.0
    #8
    Had the same issue for a while. I deleted my MBP from Kindle management and then deleted the kindle software from my MBP. I also killed off a Kindle folder in ~/Library (applications support I think). Then I downloaded Kindle for Mac again and authorized my MBP in the Kindle manager. I went back and forth on these steps until it finally took. I haven't had a problem since but I'm not sure which step actually fixed everything
     
  9. mkturin macrumors newbie

    Joined:
    Jul 29, 2010
    #9
    Deregister/register

    I am pleasantly surprised to find that deregistering and reregistering, indeed works!!! A few titles needed to be redownloaded through my Amazon account, but took seconds for each of 3 books - my entire Kindle library is now available on my Mac again. Thanks!
     
  10. king974 macrumors member

    Joined:
    Apr 17, 2008
    #10
    I had the same problem. I tried all the above recommendations, nothing worked.
    I then tried to open the folder my Kindle Content in Documents. Error message saying I didn't have the proper permissions to view folder came up. I deleted the folder.
    Kindle then gave me an error saying it could not find the folder. I clicked OK. Instantly my book appeared.

    Hope that helps
     
  11. BradleyF81 macrumors newbie

    Joined:
    May 8, 2009
    #11
    Also a problem on Win 8.1

    I'm not sure when this problem started because I rarely open Kindle for PC, but I'm thinking it must have been after the 8.1 upgrade. I tried deregistering and re-registering but it wasn't working. What finally did it for me was opening the My Documents folder, then the My Kindle Content folder, and then deleting everything in it. When I opened Kindle for PC again it asked me for my login information and then books downloaded normally again.
     

Share This Page