Kindle on the iPad is a second class citizen?

Discussion in 'iPad' started by r0k, Apr 19, 2010.

  1. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #1
    I decided I wanted to read Tom Sawyer. I downloaded it to iBooks very easily right inside the app. No problem. But I don't always have my iPad with me so I decided to get the book on Kindle.

    It was not available for free unless I was willing to download it in 8 parts! So I went to manybooks.net and found it there in Kindle format in one piece. I downloaded it and it showed up nicely in Kindle on my Macbook.

    I then emailed it to myself so I could get the same thing on my iPad and my iPod touch. No way. When I tried to open the attachment in Mail, it said there was no way to open it. I said to myself, "Yes there is!" Not to be discouraged, I tried putting the file on a network drive and opening it in goodreader and then in airsharing hd. I now have 2 copies of it on my iPad but for some reason, Kindle is not registered to handle .azw files on my iPad?!?

    Now I'm starting to get desperate so I went to Manybooks.net from my iPad. Nope. This time when I try to download, nothing happens. I try many of the formats and nothing happens. Even the mobi format doesn't work, (which should work in iBooks, right?).

    So perhaps both Kindle and iBooks are second class citizens when it comes to handling files.

    But goodreader is allowed to handle pdf files so I wrongfully assumed any program could handle any file on the iPad.

    I also tried it from my iPod touch. Manybooks.net threw me into a "babified" version of the page that didn't even offer Kindle format. So I tried Opera Mini. Still babified. So there was just no way I was able to get a file over to my iPad that my Kindle or iBooks could read without going through the "predefined" method using the apps' respective book stores and sync methods. I could use whispersync for Kindle and the iBooks book store but I couldn't simply go to a web site and download the file directly to my iPad. I couldn't even download it to my desktop and get it to my iPad using goodreader or airsharing! :mad:

    Finally, I relented and forked over a dollar to amazon for one of those "repackaged" Kindle versions that includes 4 of Twain's books, including Tom Sawyer. Still, I should have been able to grab the free version directly from manybooks.net on my iPad.

    This walled garden is feeling more and more like a walled prison.
     
  2. NJBlackBerry macrumors member

    Joined:
    Apr 5, 2010
    #2
    Calibre

    Check out a piece of software called Calibre.. That should do what you want.
     
  3. klrobinson999 macrumors 6502

    Joined:
    Dec 28, 2008
    #3
    I hope you're not blaming Apple for this....it was Amazon that divided the book. I wonder why this is the case, however.
     
  4. gwynne macrumors 68000

    gwynne

    Joined:
    Mar 11, 2010
    #4
    Yeah, I think you're placing the blame in the wrong corner. Amazon programmed the app, split that book up, and failed to support epub or gutenberg. Twisting this into a walled garden rant is a stretch at best.
     
  5. diabolic macrumors 68000

    Joined:
    Jun 13, 2007
    Location:
    Austin, Texas
    #5
    It does. I was able to convert Tom Sawyer from manybooks.net to ePub in about 30 seconds and add it into iTunes for syncing onto the iPad.

    Every walled garden usually does have a gate. :)
     
  6. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #6
    Kindle is crippled even on Amazon hardware.

    Amazon is the one who uses proprietary format.

    Apple uses ePub which is open.
     
  7. vw195 macrumors 6502

    Joined:
    Dec 27, 2008
    #7
    Apple uses Fairplay DRMed ePub which is indeed proprietary. Kindle uses .mobi which is eash to strip and convert (as long as you stay away from that topaz crap.)

    For undrm'ed use iBooks. For purchases use Kindle, at least until iBooks DRM is cracked which prob not oo long
     
  8. gwynne macrumors 68000

    gwynne

    Joined:
    Mar 11, 2010
    #8
    Apple supports open/non DRM epub books too, though, which amazon does not.
     
  9. vw195 macrumors 6502

    Joined:
    Dec 27, 2008
    #9
    Yes I use iBooks to read my ePub library
     
  10. jeffy777 macrumors 6502

    Joined:
    Mar 21, 2010
    #10
    I downloaded Tom Sawyer for free from the iBook store, but the illustations don't show up :/

    For example, it just shows a blank spot where an illustration is supposed to be, and it says the filename of the image, such as "17-144.jpg".

    Bummer....

    At least the book itself is still readable.
     

Share This Page