kingspec 128gb ssd does not work

Discussion in 'MacBook Air' started by charlies8282, Jul 15, 2009.

  1. charlies8282 macrumors newbie

    Joined:
    Feb 11, 2008
    #1
    I can tell you that after trying in every way to make it work, the kingspec 128gb ssd is not recognized by the mba first gen.
    The only way to use it is to put it inside an external usb enclosure, in this case disk utility can mount it, but when you put it inside your mba the system does not recognize it (not even the hardware). No matter if you format it, setup GUID partition table, clone block to block your drive when connected as usb.

    Perhaps someone will be able to make it work, but this is my experience.

    Hope to find a 128gb ssd drive working in the near future. :(
     
  2. Scottsdale macrumors 601

    Scottsdale

    Joined:
    Sep 19, 2008
    Location:
    U.S.A.
    #2
    How about you sell your first gen MBA, and buy a refurbished 1.86 with SSD rev B MBA??? Probably cost you less overall anyways.

    Good luck.
     
  3. mac jones macrumors 68040

    Joined:
    Apr 6, 2006
    #3
    Yes I have the 64GB version and it is a problem. I didn't even try it in the Air but It started acting funny in another machine and after the Runcore fiasco I sort of have a nack for knowing which ones are going to cause trouble.

    There's a generic brand on Ebay called the SSDfactory that I bought in the 2.5" PATA IDE form that is very good-very fast . (they also have it in 1.8 zif)

    Also, the G-monsters are getting good buzz

    (note: not sure whether these are 5mm or not)

    Lots of options for the PATA now so no need to get burned with some of the others.
     
  4. Nak macrumors newbie

    Joined:
    Feb 4, 2008
    Location:
    Portland, OR
    #4
    charlies8282,

    The PhotoFlash 128GB drive works great:

    [​IMG]

    I got it from: http://www.dvnation.com/

    I too didn't want to "buy a new car because the gas tank was empty" especially since I paid $3K for this thing and it's still in perfect condition.

    Nak
     
  5. bananas macrumors 6502

    bananas

    Joined:
    Aug 1, 2007
    #5
    Can anyone confirm this? Is this really incompatible with MBA? I cannot see a reason why this didn't work with Air.

    Does Disk Utility see the drive when booted from Leopard install DVD?
     
  6. bananas macrumors 6502

    bananas

    Joined:
    Aug 1, 2007
    #6
    also, if anyone has any idea if 128GB RunCore Pro 1.8" PATA Zif SDD works with MBA I'd appreciate your comment about the installation and quality of the drive.

    It's 3 millimeters thicker than the original drive, so that might be a bit of a challenge.
     
  7. macsation macrumors member

    macsation

    Joined:
    Apr 7, 2009
    Location:
    Washington, DC
    #7
    Could someone CLEARLY state which 1.8 ZIF Pata SSDs work on the 1st generation MBA please.
    Thanks :)
     
  8. Nak macrumors newbie

    Joined:
    Feb 4, 2008
    Location:
    Portland, OR
    #8
    What's not clear here? - Photoflash works (it's in the MBA Rev A I'm typing this on right now), Kingspec and Runcore do NOT work.

    Nak
     
  9. macsation macrumors member

    macsation

    Joined:
    Apr 7, 2009
    Location:
    Washington, DC
    #9
    Great. I was thrown off by the question of 40 vs 44 pin. SO many choices, and seemingly so many different connector/size options that, according to many forums, do not work in the Air's non-standard drive. Twas confusing. Glad that's cleared up.
    Now to decide if I'll spring for a 64gb Photofast, or sell my Air and buy a revb ssd refurb......
     
  10. macsation macrumors member

    macsation

    Joined:
    Apr 7, 2009
    Location:
    Washington, DC
    #10
  11. jrabbit macrumors member

    Joined:
    Jan 30, 2008
    Location:
    St. Louis, MO
    #11
    Photofast

    Nak is right.

    I'm also using the Photofast 128GB from dvnation.com.

    Works fine; replacing it in my first-day Rev. A was a breeze.

    Good luck!
     
  12. tuggi macrumors newbie

    Joined:
    Nov 19, 2009
    Location:
    turkey
    #12
  13. s540201 macrumors newbie

    Joined:
    Jan 28, 2010
    #13
    Kingspec KSD-ZF18.1-xxxMS are working fine with MBA rev-A & B. hope it helps.
     
  14. MadAxeManUK macrumors newbie

    Joined:
    Oct 14, 2010
    #14
    Avoid the Kingspec

    I am using (barely) a PATA KingSpec KSD-ZF18.1-128MS SSD in an MacBookAir1,1 Intel Core 2 Duo
    @1.6 GHz, having replaced my 80Gb HDD which was starting to fail.
    However, it has been an utter pain since day-1 :mad:, and I am about to return it a get my money back. It WILL work sporadically, but every time I did an OS update it will not re-boot while in EFI-Boot mode.
    There is a work around that I have round, Disk Warrior to the rescue (the best $100 I have ever spent), I have set up a 2nd partition for Emergency use only, that has DW on it. When I have probs I boot onto the 2nd partition (using the Alt key on start-up) then I can use DW to re-build to directory tree, then it works again, for a while. Far from ideal. I spoke to my local Apple Genius about it and he said that the HD is bu99ered, so not an encouraging sign.
    I will be looking for other options.
     

Share This Page