Kingston SDHC Class 10 Problem

Discussion in 'MacBook Pro' started by JoaoF, Aug 7, 2014.

  1. JoaoF, Aug 7, 2014
    Last edited: Aug 7, 2014

    JoaoF macrumors member

    Joined:
    Apr 3, 2011
    #1
    Hi guys! I have a Kingston SHDC Class 10 with 8GB and whenever I insert in on my rMBP it doesn't recognize it. I thought the problem was with the card reader however when I tried a Kingston SDHC Class 4 it worked as it should. Any tips on how to solve this?

    More info:
    1. My Canon can read the card just fine.
    2. When I reboot the rMBP with the card inserted it just stay indefinitely stuck in the :apple: logo with a rotating symbol below.
    3. Already tried both SMC and PRAM resets.
     
  2. DJJAZZYJET macrumors 6502

    Joined:
    Jun 4, 2011
    #2
    Go into disk utility and see if it recognises the card there. Try formatting and repairing the card, and hopefully it'll be able to mount.
     
  3. JoaoF thread starter macrumors member

    Joined:
    Apr 3, 2011
    #3
    Disk utility won't recognize it either. I formatted it on the camera but still unsuccessfuly
     

Share This Page