KOTOR Cheats help!

Discussion in 'Mac and PC Games' started by Arthur x, Nov 4, 2010.

  1. Arthur x macrumors newbie

    Joined:
    Nov 2, 2010
    #1
    I run a Macbook Pro 1.6.4, when I use KOTOR and I try to use cheats, I press Alt-n=~ but I have noticed that when I press Alt it freezes, does anyone know how you can open the cheat console in another way?
     
  2. bluebomberman macrumors 6502a

    bluebomberman

    Joined:
    Jan 9, 2005
    Location:
    Queens, NYC
    #2
  3. Arthur x thread starter macrumors newbie

    Joined:
    Nov 2, 2010
    #3
    I run KOTOR which came in the star wars mac pack with star wars empire at war, I am not sure what version it is...
     
  4. bluebomberman macrumors 6502a

    bluebomberman

    Joined:
    Jan 9, 2005
    Location:
    Queens, NYC
    #4
    Well, find out. Right-Click on the program icon in the Finder and pick Get Info. The version number should appear under General (right below Spotlight comments).
     
  5. Arthur x thread starter macrumors newbie

    Joined:
    Nov 2, 2010
    #5
    Version

    Version:1.03fc3 (v0)

    Does anyone know what the key combination for it is?
     
  6. Ace134blue macrumors 6502a

    Ace134blue

    Joined:
    Sep 17, 2009
    #6
    I dont recall it being alt.? I thought i was just ~ or ~ and shift
     
  7. Arthur x thread starter macrumors newbie

    Joined:
    Nov 2, 2010
    #7
    Mac Keyboard

    My keyboard, since I use a laptop doesn't have the tilde key, I use a macbook pro 17 inch. So I have absolutely no idea what the key combination is. I use the US keyboard, so help would be appreciated.
     
  8. bluebomberman macrumors 6502a

    bluebomberman

    Joined:
    Jan 9, 2005
    Location:
    Queens, NYC
    #8
    Here's the problem: You need to enable cheats first.

    1. Go to /Home/Library/Preferences/Knights of the Old Republic/. (The Home directory is your user account name with all your personal files.)

    2. You should see a file called swkotor.ini. Open it with TextEdit. (By the way, you could have skipped step one and just searched for swkotor.ini using Spotlight.)

    3. Under [Game Options], type in
    EnableCheats=1

    4. Play KOTOR and hit the ~ key (really, the ` key) to bring up the cheat console in the upper left.

    5. Give yourself 999 Charisma, and so on and so forth. You do have the cheat codes downloaded from all over the Internets, right?

    I can confirm that this works on your version of KOTOR. I can also confirm that you have a ~ key because Apple's website says so:

    [​IMG]

    Right underneath the Esc key is ~.
     
  9. Arthur x, Nov 7, 2010
    Last edited: Nov 7, 2010

    Arthur x thread starter macrumors newbie

    Joined:
    Nov 2, 2010
    #9
    No ~ key

    I have found the ~ key, on my keyboard it lies next to the left shift key.
    When I press it in game, nothing happened, when i type, I just move.

    My Game Options looks like this

    [Game Options]
    EnableCheats=1
    Enable Tooltips=0
    Keyboard Camera Deceleration=2000.000000
    Keyboard Camera Acceleration=500.000000
    Keyboard Camera DPS=200.000000
    Hide InGame GUI=0
    Use Small Fonts=0
    Hide Unequippable=0
    Tutorial Popups=1
    Subtitles=1
    Mini Map=1
    Floating Numbers=1
    Status Summary=1
    Enable Mouse Teleporting To Buttons=1
    Mouse Sensitivity=44
    Difficulty Level=0
    Auto Level Up NPCs=0
    Mouse Look=0
    AutoSave=1
    GUIsInScreenShot=1
    EnableScreenShot=0
    Reverse Mouse Buttons=0
    Reverse Minigame YAxis=0
    Combat Movement=1
    TooltipDelay Sec=1

    So, I think it is right. But ingame, When I press ` nothing happens
     
  10. bluebomberman macrumors 6502a

    bluebomberman

    Joined:
    Jan 9, 2005
    Location:
    Queens, NYC
    #10
    Are you absolutely sure it doesn't work? It's easy to miss the ~ in action, as I almost do every time I enable cheats. Look carefully at the upper left. You should see what I see in this screenshot I just took.
     

    Attached Files:

  11. Arthur x, Nov 8, 2010
    Last edited: Nov 8, 2010

    Arthur x thread starter macrumors newbie

    Joined:
    Nov 2, 2010
    #11
    No , I don't see anything. And when you do the cheats, are you supposed to move, and/or talk to people, cause when I tpe I just randomly walk around, or run towards someone and talk to them.
     
  12. bluebomberman macrumors 6502a

    bluebomberman

    Joined:
    Jan 9, 2005
    Location:
    Queens, NYC
    #12
    When you hit ~, keyboard movement should be locked out and you should be able to type in any code you wish, like in the attached screenshot. (setcharisma 999 for the win.)

    If it doesn't work, then you'll just have to play through the game without cheats.
     

    Attached Files:

  13. s3anz2, Nov 2, 2011
    Last edited: Nov 2, 2011

    s3anz2 macrumors newbie

    Joined:
    Nov 2, 2011
    #13
    EDIT: If you are a lion user, the Library is automatically hidden from your view in the finder under your username. Go to terminal, and type this
    "open ~/Library/"
    and you'll be able to find the Knights of the Old Republic in the Application Support Folder.
    This was the problem I had, I just figured I'd say it in case anyone else has it.
     
  14. Unleashed183 macrumors newbie

    Joined:
    Nov 18, 2011
    #14
    for me I found the .ini was actually in user/Library/application support/ knights of the old republic and there is the .ini. I also downloaded it from the mac app store..

    on a separate note, I really hope kotor 2 is released also for the app store
     

Share This Page