Kubuntu VirtualBox

Discussion in 'Windows, Linux & Others on the Mac' started by mshepp, Nov 26, 2013.

  1. mshepp macrumors member

    Joined:
    Jun 14, 2009
    Location:
    UK
    #1
    I'm pretty new to Linux and virtualisation so please bare with me.

    I have created a Kubuntu virtual machine using Oracle VM VirtualBox. Everything was working fine until today. When the login screen appears and I enter in my password the screen goes to console with some text and then back to the GUI login, the text is only displayed for a split second so I have no idea what the message says. Tried restarting the virtual machine but same error message.

    If I were to login via console with the same credentials it logs me in, type in sudo startx (which I read somewhere may bring up GUI), and I then get a blank black screen.

    Before this was happening there were some warnings about space running low so i followed this article to increase the partition size which has been completed successfully but issue still remains:
    http://jonmifsud.com/blog/increase-virtualbox-disk-size/

    Does anyone have any suggestions with how to correct this so I can login successfully without starting from scratch. After trawling through some posts on various Linux forums and trying out their solutions I am still having the same problem. Many of these posts are a couple of years old so hoping since then a solution has been found?

    Would be grateful for an tips or help.

    Thanks!
     
  2. Quackers macrumors 6502a

    Joined:
    Sep 18, 2013
    Location:
    Manchester, UK
    #2
    I'm not sure about in a vm but in a normal system (Ubuntu/Kubuntu) when you increase the size of a system partition you also need to resize the file system to fill up that extra size.
    In a normal Ubuntu system that would be done in the terminal with the command
    Code:
    sudo resize2fs -p /dev/sda1
    where /dev/sda1 is the partition that has been extended.
    You could try that after logging in to your normal account from the tty (the terminal type screen you are seeing).
    Then reboot the vm.
     

Share This Page