La Cie froze during backup, now won't mount

Discussion in 'Mac Basics and Help' started by Ringu, Jul 7, 2005.

  1. Ringu macrumors member

    Mar 20, 2005
    Help. I was using my 'pocket' firewire La Cie/Porsche drive to do a routine backup of my PB (OSX 10.3.9), using La Cie's own Silverkeeper software.

    For some unknown reason, my whole computer froze (first time that's ever happened) and I had to restart using the power button.

    Now, I can't get the hard drive to mount - can anyone help me out?


    PS - I've updated to the latest firmware from and still no luck.
  2. ITASOR macrumors 601


    Mar 20, 2005
    Does it show up in Disk Utility? If so, try reformatting it. This has always worked the few times mine or a friends drives didn't mount.
  3. Ringu thread starter macrumors member

    Mar 20, 2005
    Thanks for your help. So far, it just makes Disk Utility get that little whirling circle "Gathering disk information". Nothing seems to be happening.

    LaCie's 'Update Tool" can see the drive, (it just comes up with a dialogue box saying "your firmware is up to date" or something like that) but it doesn't mount it. Grrr.

    Any other ideas?

Share This Page