Lacie External drive not mounting (Long story)

Discussion in 'Mac Basics and Help' started by PkennethV, Jan 16, 2007.

  1. PkennethV macrumors 6502a

    Aug 16, 2006
    Okay, the problem first started when sometimes the drive wouldn't mount (drive is Lacie Porsche design 250GB firewire only). When I turn it off and on again (sometimes after 2 or 3 times) it would mount. I had bought this drive from an apple store in Thailand (used to live there) and the warranty was only for that store. But I took it too the Apple store in York Dale (Toronto, where I now live) to see what they had to say about it. The Genius tried it on my PowerBook and it didn't mount. He then tried it on one of the computers there and it work flawlessly. I know that it was not my firewire port because i use my iSight on it regularly. But they wouldn't look into it any further because I didn't buy it from them and didn't have international warranty. After a quick iChat with my dad who lives in Thailand, we decided to mail it Thailand and he would take it to the store. The store told us that we only needed to send the drive and not the firewire cable nor the adapter. A week later I find out that they tried it on 5 different macs there and they all worked. We concluded that it must just be something with my PowerBook. We decided not to mail the drive back to me because in a month I would be back to Thailand for my holiday and wold be buying an MBP anyway. So since (we thought) the problem was only with my PowerBook, it should work fine with my MBP. So when I bought my MBP (now in thailand) I remembered to test out the drive. The only thing was because we mailed the drive itself to thailand, and we forgot to bring the adapter with us. Well, no problem we'll just use the adapter at the store. So we did and it worked fine on my new MBP. Well, I'm back from Thailand now and eager to enjoy an extra 250 GB of space. When I plug it in...nothing, just like the PowerBook. I'm stumped. Any ideas? Oh forgot to mention, both for the PB and MBP I can feel the drive spin and the orange light comes on so it is receiving power. Disk utility etc. doesn't see it either, it's like it's not plugged in.

    thanks in advance
  2. Teh Don Ditty macrumors G4

    Teh Don Ditty

    Jan 15, 2007
    what is this adapter? by reading it that seems to be your problem
  3. GITANAJAVA macrumors regular


    Feb 3, 2006
    Have ibrik, will travel.
  4. PkennethV thread starter macrumors 6502a

    Aug 16, 2006
    The power adapter is by Jentec Technology
    "switching supply power adapter"
    model: JTA0202Y
    Ac input: 100-240Vac/1.2A 50-60HZ
    DC output +5V/2A,+ 12V/2A
    It's the adapter that came in the box.
  5. jpt11 macrumors newbie

    Sep 19, 2007
    Its definitely the adaptor

    I had the exact same problem. I changed the power adaptor and it mounts flawlessly every time. I changed it with another one, as I had two of the drives.

    Probably too late to help, but as I was searching for a place to buy a new adaptor I saw this post! Maybe it will help someone else.

Share This Page