LaCie External Hard Drive: Wake / Sleep Problem

Discussion in 'Mac Pro' started by martinvanderhof, May 29, 2008.

  1. martinvanderhof macrumors newbie

    Jan 23, 2008
    I'm on an early 2008 mac pro - used to be on a Powerbook G4. I have a 300 GB LaCie d2 Extreme external HD connected via firewire 800. Both are in 10.5.2.

    While on my powerbook, the drive behaved normally - fell asleep after no use, then awakened when I needed to access something.

    On my new mac pro, the drive behaves strangely. I only use it for backup, so it's only accessed once a day. The rest of the time I do not use it. When it's not in use, the drive sporadically wakes and sleeps. I've tried to pinpoint the cause to no avail.

    I've tried all the usual suspects: browsing the forums, checking the "hard disk sleep" preference in energy saver, switching the firewire 800 cable with usb and firewire 400, watching activity monitor to see if there's a program accessing the drive (haven't found anything, but that doesn't mean it's not there). None of it works.

    Suggestions, anyone? Thanks for your help.

  2. martinlk macrumors member


    Jun 20, 2005
    Aalborg, Denmark
    As far as I know, the "put hard hard disk(s) to sleep when possible" option has no effect on external drives, but only internal drives. It is the controller in your external enclosure that "sets a bit" on your hard drive, causing it to sleep after a period of inactivity. You cannot change this from within OS X unless the manufacturer provided some kind of utility.

    If you have problems with your drive waking too often it is probably because the OS tries to access it frequently. I have en external firewire 800 drive myself, and it also wakes more often than I'd like--e.g., it will sometimes wake when opening a web page in Safari.

    Hope you understand what I'm saying.
  3. martinvanderhof thread starter macrumors newbie

    Jan 23, 2008
    Yeah, I see what you're saying. I wish there was a solution, or at least a way of troubleshooting the issue. Bugga me.
  4. kaaskop macrumors newbie

    Aug 2, 2008
    its Spotlight

    go to System Preferences>Spotlight>Privacy and add your disk to the exceptions list. it stops OSX (Spotlight) kicking off the disk ..... at least it did for me.

Share This Page