lacie external HD problem

Discussion in 'Mac Basics and Help' started by derajfast, Aug 19, 2005.

  1. derajfast macrumors 6502a

    Mar 24, 2004
    i got an external lacie 320 big disk firewire 800 HDD and it worked fine for a few i plug it in, and it doesnt mount on my desktop or when i open up macintosh HD....i tried repairing disk permissions with disk utility but it said there was nothing to repair....disk utility recognizes it but it wont mount at all......and when i unplug it or turn it off, i get the error message that says it wasnt disconnected properly....
  2. wdlove macrumors P6


    Oct 20, 2002
    I would recommend that you contact Lacie directly. Sure sounds like a problem on their end.
  3. Sedulous macrumors 68020


    Dec 10, 2002
    Have you tried to "Repair Disk"? Unless you are booting from the drive, you can't really repair its permissions.
  4. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    LaCie has had some problems with their external power supplies - like WDlove says, call 'em up.
  5. stevie macrumors newbie

    Aug 20, 2005
    as if they will answer. further more no toll free number. email customer support gets you form replies and then a send it in and we'll check it out. I went through the same thing, wiht no resolution yet!

Share This Page