Lacie hard drive quit

Discussion in 'Mac Accessories' started by bandaid, Oct 2, 2005.

  1. bandaid macrumors newbie

    Oct 2, 2005
    My 2 yr old Lacie Hard drive just quit. The power supply lite is flashing. The blue "on"lite will not work. I've tried a different power supply and it too flashes. It just quit out of the blue and has been working fine. All my other Lacie drives work ok on this computer. I tried it on another computer to no avail. I think this thing has given up...and I want to know if there is a way to rescue the data on it. Or..preferably get it working again. It is off warrenty.
  2. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    Rescuing the data -- you have a reasonable chance of removing the hard drive mechanism from the case, and installing it in either another case or in a G4 PowerMac (something with IDE connections and more than one hard drive capability) to recover the data.

    Your symptom is that the blue light flashes and you never hear the drive mechanism spinning up, correct?

    I'd give you about a 60% chance there is nothing wrong with the drive mechanism. Your external has 3 components that could go wrong -- the power supply, the FW-IDE bridge card, and the mechanism itself (plus the respective cables and connectors between them of course.)
  3. bandaid thread starter macrumors newbie

    Oct 2, 2005
    lacie drive

    Right...but it is the powersupply lite that is flashing...not the blue lite..the drive does not spin up. I did take it apart, and put the drive into another case, and the drive spins up. So I will probably install it in place of my 60 in my G4. However I would like to get the mechanism to work, I don't know if Lacie or anyone actually fixes these.

    PS is there a way to get these posts forwarded to my emai?
  4. ragnarwantsmbp macrumors newbie

    Aug 23, 2007
    Winnipeg, Canada
    Hi Bandaid,

    Just read this old post of yours from 2005 while I'm dealing with the exact same problem with a 320Gb D2 Quadra. Just won't power up. Tried different power supplies . . . the supplies all show a solid green power indicator until plugged into the drive - then the power supplies green light blinks and the drive is totally unresponsive.

    Wondering if you ever solved your issue, and if so, how?

  5. skorpien macrumors 68020

    Jan 14, 2008
    Seeing as your drive is completely unresponsive, I'd assume it was the enclosure that is busted. I'd try to open it up and re-seat the hard drive in a different enclosure or hard drive dock.

Share This Page