LaCie Setup Assistant - can I redownload it?

Discussion in 'Mac Basics and Help' started by stillill, Nov 9, 2009.

  1. stillill macrumors member

    Apr 3, 2008
    Have a Rugged 500gb Fw800/400/USB disk. Am running it with Snow Leopard, and when Setup Assistant started the first time it said it couldn't work with Snow Leopard. I followed instructions etc to format using Disk Utility for Mac which went fine.

    However, I've inadvertently deleted all the docs and backup tools that came with the drive (didn't copy them off before the format). I see I can download the individual pdf and .zip files from the LaCie site, but cannot find the Setup Assistant anywhere. Is it possible to re-download this onto the drive so when I plug it in it will show up? (ie, it'll act 'like new')?

    I posted on the LaCie forum, but wondered if anyone here was able to help.

  2. GimmeSlack12 macrumors 603


    Apr 29, 2005
    San Francisco
    You really don't need that "Setup Assistant". Just reformat the drive with Disk Utility and that's the same thing as "Brand New".
  3. jeremyjdodd macrumors newbie


    Jun 29, 2009
    When I attempt to connect this drive using my eSATA via ExpressPort connection, the drive does not show up in Disk Utility.

    I am not sure why this would occur, since I can access it when connected using USB 2.0 and see that it's HFS+Journaled.

    Any ideas on where I can download the Setup Assistant, or how to take care of this problem?

    For background, I recently had the hard drive replaced. I did a restore from a Time Machine drive. Prior to the failure, the eSATA connection worked fine. Post hard drive replacement, it does not, which is why I think I need to download and run a new copy of Setup Assistant.

  4. iWind130290 macrumors member

    Aug 30, 2011
    Ha Noi, Viet Nam
    Just use Terminal to re-format. Disk Utility can't see your ExtenalHD but u still can access when it connect. So, I think that Terminal can see it :)
  5. jeremyjdodd macrumors newbie


    Jun 29, 2009
    Thanks for the reply, IWIND.

    Turns out I needed to install a different driver for the expresscard esata adapter. Once I took care of that, it worked like a charm. Better than before, even.

Share This Page