Lacie Thunderbolt drives

Discussion in 'MacBook Pro' started by police340, Oct 5, 2017.

  1. police340 macrumors regular

    Joined:
    Jul 11, 2011
    #1
    Hello,

    I have two Lacie 2TB SSD drives with Thunderbolt connections. They dont seem to be powering up with my new Macbook Pro USB-C connections. Do these now need to be powered to be able to use them with the Pro? My old pro had no probelm powering them.

    Thanks,
    Bill
     
  2. ZapNZs macrumors 68020

    ZapNZs

    Joined:
    Jan 23, 2017
    #2
    Which models are these specifically? The Rugged series? Are you using the Apple Thunderbolt 3 to Thunderbolt 2 adapter?
     
  3. police340 thread starter macrumors regular

    Joined:
    Jul 11, 2011
    #3
    Yes, the rugged ones with the apple adapters. I was on beta, now downloading high sierra. we'll see what happens fter that. thanks.
     
  4. ZapNZs macrumors 68020

    ZapNZs

    Joined:
    Jan 23, 2017
    #4
    That is strange because the Apple adapter supports bus power and I've seen the another TB3-->TB2 adapter work with that specific LaCie. Do you have any other TB/TB2 devices you could try to see if perhaps the adapter is malfunctioning?
     
  5. police340 thread starter macrumors regular

    Joined:
    Jul 11, 2011
    #5
    Yes, Ive tried two dofferent drives with two different adapters. I have ne more drive I will try. Thanks.

     
  6. police340 thread starter macrumors regular

    Joined:
    Jul 11, 2011
    #6
    Looks ot be a bad adapter. apple is replacing.
     

Share This Page

5 October 5, 2017