Lag/stutter when switching spaces (ML and rMBP)

Discussion in 'MacBook Pro' started by KimHansenDK, Aug 10, 2012.

  1. KimHansenDK macrumors 6502

    Joined:
    Jul 29, 2011
    #1
    I finally got a new replacement (3rd) for my Retina MacBook Pro (2.3/16/265) without any dead pixel and ghosting issues. Now I am happy as this is really an amazing laptop.

    The one I got had ML preinstalled and have noticed that when I switch between space with a 'normal' flick on the trackpad there seems to be a slight stutter/lag - especially in the end of the animation. Does anyone have this problem? And is it software or hardware related? If I do the flick more firmly and fast the stutter/lag seems to be at a minimal - and there is not stutter/lag when switching spaces using the 'tab' key - the same goes for mission control and launchpad.

    I know that there have been a billion threads about this but I cannot seem to find a concluding answer.

    Thanks :)
     
  2. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
  3. KimHansenDK thread starter macrumors 6502

    Joined:
    Jul 29, 2011
    #3
    Hmm does not seem to fix it for me. Maybe it will be fixed in a future update :)
     
  4. StefanYFC macrumors member

    Joined:
    Jul 20, 2012
    Location:
    Toronto, Canada
    #4
    I've got the same thing, not awful but noticeable. I figured it would get panned out eventually.
     
  5. KimHansenDK thread starter macrumors 6502

    Joined:
    Jul 29, 2011
    #5
    Yeah I have come to the same conclusion. Everything else is just perfect on my replacement, so will not give this one up. It will be sorted out with an update I think :)
     
  6. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #6
    Do you see less 'stutter' when switching spaces in mission control? I see some stutter with the dock unhidden, but hiding or switching spaces in mission control and the stutter disappears...
     
  7. KimHansenDK thread starter macrumors 6502

    Joined:
    Jul 29, 2011
    #7
    In mission control there is not lag/stutter what so ever.

    But I have now noticed 1 time that when the machine is sleeping (closing the lid) then when I open it again and log in the dock seem to flicker a bit (especially when going to mission control). If i put it ti sleep and logged in again there were no problems.

    I think these are only small software bugs that need to ironed out with updates. Don't you think?
     
  8. Hazza42 macrumors newbie

    Joined:
    Aug 13, 2012
    Location:
    Hampshire UK
    #8
    Possible Solution

    Sorry to bring back an old(ish) thread, but there seems to be a select few people who have this frustrating issue, including me, and I've just found a solution that no-one else seems to have posted.

    It's simple really, remove spaces. I have at least 8 different desktops in my Mission Control, and I'm never using all of them. To make it worse, they all have different backgrounds that change randomly every 15 minutes to a different wallpaper from my massive library.
    Getting rid of spaces is simple for those who don't know: Just hover over a "Desktop" in Mission Control and then click the X that appears in the top left to close it. I did this until I was down to 5 desktop spaces and the whole thing runs smooth as silk now =]

    Someone else please give this a try and see if it works for you too!
     

Share This Page