Lag when waking up from Sleep

Discussion in 'MacBook Pro' started by Cassadian, Sep 17, 2012.

  1. Cassadian macrumors regular

    Joined:
    Sep 4, 2012
    #1
    I recently purchased a Macbook Pro Retina and it is about 7 days old. I randomly experience lag after opening the lid after it has slept from anytime ranging from several minutes to twelve hours. I don't always experience it but when I do I see the log-in screen but have no ability to type a password for several seconds (about 5-10 seconds).
     
  2. tatical macrumors member

    Joined:
    Jun 7, 2009
    #2
    This happens to me sometimes too. After its been asleep for a while, I have to wait a few seconds until I'm able to type in my password. It hasn't happened in the past few days, but it was happening a lot when I first got it (and after the 10.8.1 update also).
     
  3. DT39 macrumors newbie

    Joined:
    Aug 30, 2012
    #3
    I get this on mine to after updating to 10.8.1 never had it before then that i recall. No great problem but hoping 10.8.2 will fix it!
     
  4. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #4
    Has anyone solved this issue?

    It annoys me so much! I heard that by disabling safe sleep it foxes it but I shouldnt have to do this on my 2k computer!

    TA
     
  5. overmind macrumors newbie

    Joined:
    Apr 2, 2013
    #5
    I think it has something to do with RAM paging

    My technical definition of the problem may be vague, but when you open the lid, the Mac loads the previous state from a sleepimage (where it was at when you closed the lid or it went to sleep). For example, if you have 16GB of RAM, it loads a 16GB sleep image upon waking it from sleep, therefore it will take several seconds, and it might take a shorter time if you have less ex. 8GB and so on.

    I have tested this, and I read it somewhere on these forums too, and it seems to be in the lines with this issue. There is also a fix to remove this issue:

    There should be a file called 'sleepimage', which you can remove. It will be rebuild if needed.

    You should check your Power Management Settings in the Terminal via pmset

    pmset -g | grep hibernatemode

    The default should be "hibernatemode 3", meaning that RAM contents is written to the disk upon sleeping. To test if the reading of the sleepfile is causing your sluggish behaviour you can disable 'safe sleep' with

    sudo pmset -a hibernatemode 0

    I dont know if this will help for your exact problem, but it might be worth a try!


    (Sorry for my English, but its not my native language)
    :)
     
  6. chriscl macrumors 6502

    chriscl

    Joined:
    Jan 4, 2008
    Location:
    Stuttgart, Germany
    #6
    I have found that if I leave an external USB drive plugged into my MBP (for example, my Time Machine drive) my MBP will never fully go into "deep sleep" when the lid is closed (and its sat on the desk).

    When nothing is plugged into it however, it will go into the "deep" hibernation after being slept for a couple of hours.

    This is, as I understand it, by design.
     
  7. Count Blah, Apr 2, 2013
    Last edited: Apr 2, 2013

    Count Blah macrumors 68030

    Count Blah

    Joined:
    Jan 6, 2004
    Location:
    US of A
    #7
    I have this on the cMBP as well. Most of the time, I open the lid and the screen pops up withing a second or two. But once in a blue moon, I open up the lid and just stare at a blank screen for anywhere from 10-20+ seconds. Hitting buttons does absolutely nothing to speed this process along. What I do notice is that the machine will always begin the strobe light/sleep thing again, right before the screen does eventually start up again.

    I considered going to an Apple Store to have a look, but then figured that it would never do it when I actually want it to. Perhaps I can try to find a pattern that will always cause this. Who knows.

    PS - I have nothing plugged into the MBP, and this still happens.
     
  8. 5aga macrumors 6502

    5aga

    Joined:
    Feb 18, 2003
    Location:
    Gig City
    #8
    same thing happens on my cMBP. actually it happened last night. I believe its a ML issue but not entirely sure.
     
  9. Count Blah macrumors 68030

    Count Blah

    Joined:
    Jan 6, 2004
    Location:
    US of A
    #9
    The G4 powerbooks were INSTANT on/off with the lid. With the switch to Intel, it has taken much longer both on/off. NOW, this thing is a pain.
     
  10. kittencounter macrumors member

    Joined:
    Mar 22, 2013
    #10
    sudo pmset -a standbydelay 86400

    Change the value to set after how long it will go to deep sleep. It will wake instant if you wake it up in that time.
     
  11. atMac macrumors 6502

    Joined:
    Jun 20, 2011
    #11
    Are you also noticing a jumpy mouse? I am seeing that also when my battery starts to get low, for some reason the touchpad gets less responsive.
     
  12. EmptyCalm macrumors member

    Joined:
    Jan 24, 2008
    Location:
    earth
    #12
    this happens to me often didn't know it was an issue. still pretty damn fast (coming from a 07 macbook)
     
  13. pricej636 macrumors 6502

    Joined:
    Mar 30, 2010
    Location:
    Colorado
    #13
    ^^This.
     
  14. codemister933 macrumors newbie

    Joined:
    Jul 16, 2013
    #14
    lid lag

    not only is there a lag to enter my password as you all are saying. There are times (like if I close my lid and try to open it right after) that my screen just stays black and I have to hold the power button down to wake it back up. Lag follows.
     
  15. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #15
    Interesting thread because I have only had my MacBook Pro 13-inch mid-2012 for four months now and once in a while I confront this exact same problem. Specially with the stock 5400rpm HDD that came with this machine but it's been a whole lot less frequent when I switch over to a SSD. Saddens me that nobody has any idea as to the cause.
     
  16. thekb macrumors 6502a

    Joined:
    May 8, 2010
    #16
    I have this same problem. SOmetimes it never lets me type a password at all and I have to wait for it to go to sleep again. Then I tap any key and it will usually let me type the password. Sometimes, as someone else said, I have to use the power button to get it to wake up and every once in a while I actually have to press and hold the power button to kill it completely before it will work.

    This is very aggravating. I experienced this with Microsoft laptops, but thought I'd left those days behind when I went Mac.
     
  17. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #17
    We do know... It's the computer transferring the contents of the ram from the hard drive back onto the ram when the computer wakes. It's called Safesleep.

    If you want to disable it you can, see post 5. However if your battery dies you will lose unsaved work.
     
  18. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #18
    But then if its a feature does it mean it's a bug in its implementation ?
     
  19. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #19
    I have no idea, but the minute I disabled it was the minute I stopped worrying about it.
     
  20. locoboi187 macrumors 6502a

    Joined:
    Oct 3, 2012
    #20
    Yup I used that trick last year to fix my rMBP sleep wake problems. Also unchecked the option to have your HDD sleep whenever possible from Settings.
     
  21. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #21
    I have done that one, no problem. I send in my SSD over to the manufacture and am expecting a new drive soon. Manage to speak with a technical advisor from OWC who found it odd that I should be experiencing my particular issue since the drive has been in the market for two years now and never had my problem reported. And since it started happening around the one month timeframe I wanted to be safe than sorry. Hope it goes well, if not, I am afraid that I'll be wishing I hadn't bought from them.
     

Share This Page