Laggy/choppy macOS on MBA 2014 13" after SSD replace

Discussion in 'MacBook Air' started by MSSC, Oct 23, 2017.

  1. MSSC, Oct 23, 2017
    Last edited: Oct 23, 2017

    MSSC macrumors newbie

    Joined:
    Mar 21, 2017
    #1
    Hello!
    So… All of the history starts, when i've sold my 2007 Mac Pro. I was planning to buy a brand new 2017 Macbook Pro 15", but meanwhile i found Macbook Air 13" (2014 model) very cheaply but without SSD and Magsafe adapter. I've bought it, replaced battery, bought Magsafe 2 adapter, and finally, after month of searching, SSD (meanwhile was using Ubuntu from USB flash stick). I have installed it, and installed macOS Sierra. First thing i noticed on installer, it was very laggy. I thought "Hey, maybe my usb stick is very slow, i bet on ssd it will work 100% better". But after finishing the installation… well… it was lagging even more. After checking Usage Monitor, i've noticed system_kernel process eating around 60-70% of my CPU! I immidietaly searched in google for that kind of stuff, but most of results were about 2011 Macbook Pro, and SMC/PRAM reset did not help, i've taken out the battery and replaced it with original one, didn't help. I was willing to delete KEXT responsible for SMC (as suggested on thread) but i didn't find suitable one in folder. So i decided to download and install High Sierra, maybe it may fix the problem, but it didn't. When installing from usb drive (no matter if upgrading Sierra or installing clean) it gives me error about unrecognized system firmware, and after reboot it cannot find OSInstall.mpkg file. Tried moving this file to directory by terminal, tried installing in HFS+J mode, but it doesnt want to work. One plus of this installer is that, it is not lagging as much as the Sierra one. I've tried to download and install Sierra from another source (damaged installer, idk) but still the same. Finally i've decided to install Mavericks from internet recovery, but still the same issue. I think, it's becouse of the SSD being from another model (propably 2013) and being unrecognized by the SMC. As said, resetting it did not help. There is no option of replacing SSD, they are very rare there were i live (Poland) and if you manage to find one, they are also very expensive. Maybe upgrading firmware to 2013 model would help? Maybe some KEXTs? I dont have any idea, im so freakin bored of this… But any help would be appreciated, thanks!

    P.S. Sorry for my not that good english, as i said, im not living in english country ;)

    EDIT: spent some time in System Console and didnt find anything interesting
     
  2. madrich, Oct 24, 2017
    Last edited: Oct 24, 2017

    madrich macrumors 6502

    madrich

    Joined:
    Feb 19, 2012
    Location:
    World Class City of Chicago
    #2
    Have you tried running the Disk Utility for repairs?i Also, are you sure that the OSX has completed its indexing? Sometimes this can take a couple of days.
     
  3. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #3
    Where did you get the SSD? Is the fan running at high speed all the time? Possible liquid damage?

    Installing High Sierra will automatically update the bootrom.
     
  4. RedTomato macrumors 601

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #4
    I agree something's wrong with the hardware, probably the internal SSD. Is it actually an original apple SSD? Also you shouldn't be needing to dig around in Kexts at any point.

    One thing that people from Windows / Linux backgrounds sometimes get wrong about OSX is that it's far more fussy about what goes where. Usually it's best to just leave all the system files and app files where they are supposed to be. I messed up my first two installs by trying to customise the OS. Now I just leave it alone, and focus on getting work done.

    Have you tried a 100% default standard install?

    Also, have you tried getting a cheap, small external SSD (40 or 50GB) and a good USB3 enclosure, and booting the Macbook from the SSD? You should be able to run OSX from the external SSD. It'll run almost as fast as the internal SSD and it will help to troubleshoot issues. You should be able to resell the external SSD quite easily when you're finished with it.
     
  5. MSSC thread starter macrumors newbie

    Joined:
    Mar 21, 2017
    #5
    So...
    This is original Apple SSD, (samsung model), even its pcb is black.
    After installing sierra, i thought that it may be spotlight indexing and i've waited until it finished its progress (progress bar in spotlight) but it was working exactly the same.
    Fan is running at normal speed, both in installator, system and in ubuntu.
    I've NOT messed anything with the system, it was 100% clean install (even tried forcing hfs+ when installing hs).
    I dont need external macOS ssd, if we figure out any possible solution, linux on pendrive will also work great.

    I still think its something about disk compatibility, i installed ubuntu (again ubuntu :3) on the internall ssd and it works like a charm. But it is macbook, so i would like to use macOS on it. Dont have any ideas.
     
  6. RedTomato macrumors 601

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #6
    Could you expand more on this?
    You shouldn't need to be forcing hfs+.

    Are you formatting the SDD in Mac OS Extended (Case-sensitive, Journaled)?
    Don't do this. Go for non-case sensitive.

    If you already have OSX working, you should be able to download a clean and legal OSX installer for that version (or the next one) direct from the Apple App Store. It doesn't really matter which version of OSX, as long as it's from the App store. You can now create an install USB, and use that to erase the SSD and start with a fresh install.

    Once that new install is working you can then update OS to the latest version.

    Shouldn't be happening.

    Were you able to follow exactly this procedure? (from https://macpaw.com/how-to/clean-install-os-x-mavericks-on-my-mac) It seems one of the steps is going wrong.


    Clean Install OS X Mavericks
    Once you’re all backed up, it’s time to clean install Mavericks. Follow the steps below:

    1. Create a bootable drive using a USB for OS X Mavericks. Don’t know how? OSXDaily has a nice little article on how to create one.
    2. Plug in your bootable USB drive and Restart your Mac while holding the Option key. Make sure to keep it pressed down!
    3. When it restarts, you’ll have a few options. Choose your USB Installer.
    4. Next, select the Disk Utility option.
    5. In the window, at the top of the left bar, select your Mac’s Main Drive.
    6. Next to the First Aid button at the top, click the Erase button.
    7. Now, near the center of the window, select the Format drop-down list and select “Mac OS X Extended (Journaled)” as the type.
    8. Click Erase (this will erase your main drive) and allow time for the drive to format.
    9. When it’s finished, close out Disk Utility and select “Install OS X” from the menu.
    10. Select your main drive and install an amaizing OS X Mavericks on it.
    Follow the install instructions and enjoy your newly clean-installed OS X Mavericks.
     
  7. MSSC thread starter macrumors newbie

    Joined:
    Mar 21, 2017
    #7
    Oh my God...
    I know how to create macOS install USB, as i said i've created two of them (Sierra amd High Sierra) every time erasing SSD before install, and then, i've installed mavericks using internet recovery ALSO erasing SSD, but the same thing happens....
    Every time, i was erasing to HFS+J, tried installing High Sierra 3 times: on disk formatted to HFS+J, on disk formatted to APFS, and on disk formatted to HFS+J but forcing using it on the installer, and every time the same thing happens.
    Missing Osinstall.mpkg and unrecognized system firmware happens ONLY when installing HS.
     

Share This Page

6 October 23, 2017