Laggy Launch Pad and Graphics

Discussion in 'Mac OS X Lion (10.7)' started by tpho, Feb 20, 2013.

  1. tpho macrumors newbie

    Joined:
    Aug 6, 2012
    #1
    I have the late 2007 black Macbook (http://www.everymac.com/systems/app...-2.2-black-13-late-2007-santa-rosa-specs.html)

    It has 4GB of RAM and I recently did a clean install of OS X Lion. Any kind of graphics processes is a little laggy compared to Snow Leopard.

    Some things I've noticed are-

    -Launch pad: A little hitchy when opened/scrolling. The icons jiggle when you hold down the ALT-key but it lags as it jiggles.

    -YouTube: Videos are a little laggy.

    -Screensaver: Also laggy.

    -No ripple effect from widgets.

    Running in 32-bit/64-bit mode doesn't change anything.

    Anyone have any suggestions?
     
  2. Goftrey macrumors 68000

    Goftrey

    Joined:
    May 20, 2011
    Location:
    Wales, UK
    #2
    I'm afraid that's what you can expect running Lion on 5 year old integrated graphics. There's no way around it, I actually ended up downgrading back to Snow Leopard due to the pretty horrific graphics performance shown on my late 2006 MacBook.
     
  3. Tesselator macrumors 601

    Tesselator

    Joined:
    Jan 9, 2008
    Location:
    Japan
    #3
    Ya, OS's are optimized for the hardware they were written for.

    Kinda like steam engines vs. the internal combustion gasoline engine; if you try to fuel the later with coal and water it's going to cough and sputter. :)
     

Share This Page