laggy Youtube fullscreen

Discussion in 'iMac' started by iMcLovin, Mar 28, 2013.

  1. iMcLovin macrumors 68000

    iMcLovin

    Joined:
    Feb 11, 2009
    #1
    I got the top end iMac late 2012 - everything maxed out.
    But still I experience lag when playing a youtube video on full screen. It happens for me no matter if the video is 1080p or 320px - so it seems to be youtube being extremely bad optimized. But again, even if badly optimized, a i7, 680mx imac with 32 gb of ram should be able to play youtube in fullscreen without lagging.
    anyone else experience this ? ANy tips on how to fix ?
     
  2. iMcLovin thread starter macrumors 68000

    iMcLovin

    Joined:
    Feb 11, 2009
    #2
    never mind, it was a chrome/flash plugin problem :)
     
  3. Jonathan20022 macrumors newbie

    Joined:
    Feb 11, 2013
    #3
    I posted about this a month or so ago, and the fact that I got no help was pretty atrocious considering the volume of people that own the same iMac as I do and how many people post here on a daily basis.

    Either way, everything but Chrome is miserably slow on fullscreen even on 240p. Uninstalling Flash Player and running Chrome with it's built in plugin improves it greatly, but it does still have an occasional lag spike. Pretty annoying, but whatever better than nothing. But to even achieve this, I can only have it by itself or a max of >10 tabs open at the same time. Forget about it with anything else open besides the browser, what a nightmare. My Late 2012 Macbook Pro has no issues with it whatsoever.

    I've been dual booting Windows 8 since I got it (The iMac), and it's shocking how smoothly flash player runs on it via the New Internet Explorer even with programs running in the background like Skyrim and Bioshock Infinite.
     

Share This Page