laging while running garageband with big files, what should i do/upgrade?

Discussion in 'Mac Basics and Help' started by benlangdon, Feb 20, 2009.

  1. benlangdon macrumors 65832

    benlangdon

    Joined:
    Jan 13, 2008
    #1
    i need some advice on what i need to do or to get, to make my computer run better.

    my problem is when running garage band and i have large files, everything lags. all the files are drum beats and i did notice if i didn't have the "view / hide track editor" window open it ran smoother but i need it open. i use it to play along with when learning new songs and such. so it must be open all the time.

    so...
    what is lagging here?
    my cpu runs at about 100% while doing things, so... i need a faster computer?
     
  2. jackerin macrumors 6502a

    Joined:
    Jun 29, 2008
    Location:
    Finland
    #2
    More RAM is always good (unless you have it maxed out already). You can also try disabling the track effects like echo and reverb for each track, that should also ease the processor load a bit.
     
  3. benlangdon thread starter macrumors 65832

    benlangdon

    Joined:
    Jan 13, 2008
    #3

    ok so i went through preferences and didn't find anything like that.
    could you point me in the right direction
     
  4. ashjamben macrumors 6502a

    Joined:
    Oct 28, 2007
    Location:
    Shanghai, China
    #4
    echo and reverb are controlled separately on each track. press the track info button in the bottom right hand corner, then details at the bottom and they at the bottom of that. that might give you some more power by turning them off.

    trying posting this in the digital audio forum,, you might get some more help there
     

Share This Page