Landscape mode in iMessage?

Discussion in 'iPhone' started by VydorScope, Nov 9, 2011.

  1. VydorScope macrumors regular

    VydorScope

    Joined:
    Oct 12, 2011
    #1
    Ok, I must be missing something simple here, but when I pivot my iPhone 4s so that I can type with both thumbs in most apps the screen pivots to a landscape orientation which is great... but that does not work in the messaging app? How do I fix that?
     
  2. macteen94 macrumors newbie

    Joined:
    Nov 6, 2011
    Location:
    Oregon
    #2
    Check if you have the rotation lock active. It should rotate just like it has since the original iOS, (Back then just called iPhone OS) 1.1.1, back in 2007
     
  3. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #3
    Actually, this feature didn't come to iOS until iOS 3.

    Anyway, double tap the home button, swipe right on the multitasking bar, and make sure your orientation lock isn't on. It would also help to clear your multitasking tray.
     
  4. VydorScope thread starter macrumors regular

    VydorScope

    Joined:
    Oct 12, 2011
    #4
    Rotation lock is not active, and it does rotate in other apps. Tested it in Safari for example, rotated fine in that.

    I guess I'll try rebooting the thing.
     
  5. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #5
    Reboot or soft reset should do the trick then.
     
  6. VydorScope thread starter macrumors regular

    VydorScope

    Joined:
    Oct 12, 2011
    #6
    Not sure what soft reset is, but I held the power button till "slide to turn off" or something like that comes up, then did the slide so that it powered down, and the gave it a bit of time off and powered back up. Rotating now. Wonder what happened?
     
  7. MarcBook macrumors 6502a

    MarcBook

    Joined:
    Jul 13, 2008
    Location:
    Jersey, Channel Islands
    #7
    I found that my iPhone 4 previously refused to rotate on a couple of occasions; a restart was required each time. Probably just a software bug and not something to worry about.
     
  8. reid0807 macrumors newbie

    Joined:
    Apr 11, 2013
    #8
    Still not fixed on iOS6?

    The fact that this thread is almost 2 years old is a little disheartening. I just recently switched to an iPhone 5 from a windows phone. Overall I'm pleased (I've been using an iPad for about a year), but I am disappointed that my iMessaging occasionally locks into portrait mode. A reboot is the only way to fix this. For the money a new iPhone costs and the duration of this issue, you would think Apple would have it corrected. Are there others who still have this problem, or is is somewhat of a fluke thing?

    (FYI, the orientation is NOT locked, landscape mode works great in Safari, Calculator, and every other landscape enabled app. It's just in iMessage that it occasionally has issues.)
     
  9. FilthyHorse macrumors newbie

    FilthyHorse

    Joined:
    May 18, 2013
    Location:
    New York, NY
    #9
    Given that other apps ARE able to rotate but imessage cannot, a simple power down of the phone should fix the problem.

    I love it when you tell someone something like "rotation lock is NOT on" and their answer is emphatically "your rotation lock is on"
     
  10. coolio93 macrumors 6502

    Joined:
    Apr 15, 2013
    Location:
    Houston, TX
    #10
    I've had this problem from time to time, but in my experience a reboot is not necessary. Just open the multitasking tray and quit messages. Once you restart the app, it should work.

    Every phone has minor bugs like this here and there. It's always good to be proactive and send apple an email so that they can fix the issue in the next release of ios.

    http://www.apple.com/feedback/iphone.html
     

Share This Page