Resolved Language and Region Settings Resetting

Discussion in 'OS X El Capitan (10.11)' started by bluemutiny, Oct 20, 2015.

  1. bluemutiny, Oct 20, 2015
    Last edited: Oct 20, 2015

    bluemutiny macrumors newbie

    Joined:
    Aug 6, 2014
    Location:
    Auckland, New Zealand
    #1
    On one of the accounts on my Mac, the Region is wrong and as such it's stuffing up things like matching contacts with phone numbers. I change it, restart relevant apps and everything works - Until I log out or restart, then it goes back to "United Kingdom (custom)".

    I also noticed that none of the other settings in that preference pane, including changing the language, reset after a restart. I've tested on other accounts and it works as expected, so it's specific to that account and not an issue with the region.

    Any ideas?

    Tried but failed:
    Resetting permissions and ownership for all files in the account;
    Resetting PRAM (Goatllama)
     
  2. Goatllama macrumors 6502a

    Goatllama

    Joined:
    Jun 24, 2015
    Location:
    Mountaintop Lair
    #2
  3. bluemutiny thread starter macrumors newbie

    Joined:
    Aug 6, 2014
    Location:
    Auckland, New Zealand
    #3
  4. Goatllama macrumors 6502a

    Goatllama

    Joined:
    Jun 24, 2015
    Location:
    Mountaintop Lair
    #4
    This sort of seems similar: https://discussions.apple.com/thread/6493816
    Most people there were having the best success with reinstalling the OS, it seems. I feel like there might be a simpler solution, but that's what I've found so far.
     
  5. bluemutiny thread starter macrumors newbie

    Joined:
    Aug 6, 2014
    Location:
    Auckland, New Zealand
    #5
    Yeah not going down that road just yet. I tried updating to 10.11.1 beta to no avail, I presume it's a preference file stuff up but I'm just not sure what preference file.
     
  6. bluemutiny thread starter macrumors newbie

    Joined:
    Aug 6, 2014
    Location:
    Auckland, New Zealand
    #6
    Sussed it, for now at least. ~/Library/Preferences/ and deleted .GlobalPreferences.plist. Changed settings, logged out/back in, worked.
     
  7. Goatllama macrumors 6502a

    Goatllama

    Joined:
    Jun 24, 2015
    Location:
    Mountaintop Lair

Share This Page