Language input settings keep switching

Discussion in 'macOS' started by Funky Bibimbap, Aug 14, 2007.

  1. Funky Bibimbap macrumors newbie

    Joined:
    May 11, 2007
    #1
    I usually have more than one language activated in the input menu, and the settings keep switching for some reason.
    For example, I have U.S. input activated, and when I use a keyboard shortcut for a tool in Photoshop it changes to Korean and the Korean input bar opens up.

    Why is that and what can I do about it?
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Well, assuming you're using Tiger, a few things you might double check:

    In the Input Menu section of the International pref pane, make sure that the "select next" and "select previous" key combinations aren't set to something that you also use in, say, photoshop.

    For example, I prefer the old-style command-space shortcut (and use it constantly), but in 10.4 that defaults to Spotlight, so I need to change the Spotlight setting to something else (it does warn you in this case, but not if it's the same as a Photoshop command).

    The other thing to check would be the Input Source Options section of that prefpane; I've found that if you have "Allow a different input source for each document" selected, it has a tendency to get "stuck" in one input source and keep switching to it whenever the focus changes. Using "Use one input source..." clears it up, though.

    Well, almost... I have occasionally seen an issue where Camino keeps changing the keyboard when I click on its location bar, but that's erratic and uncommon.
     
  3. Funky Bibimbap thread starter macrumors newbie

    Joined:
    May 11, 2007
    #3
    Thanks! Actually I did not have "Allow a different input source for each document" selected and now that I have selected it, the setting doesn't change anymore. Don't know why the opposite works for me but it does.
     

Share This Page