Laserjet 1022 problem

Discussion in 'Mac Accessories' started by baxlobs, Dec 12, 2012.

  1. baxlobs macrumors regular

    Joined:
    Nov 21, 2012
    Location:
    Suffolk UK
    #1
    I have been setting up my new iMac, (moved from Windows) I attached my printers today. The Canon ip4600 setup just fine, I was able to download the Canon print utility and it works OK.

    The Laserjet however prints one page and then all 3 lights flash and nothing further can be done, switching off and on clears the lights and one more page can be printed. :(

    Any ideas, are there likely to be newer drivers, or is it a problem with Mountain Lion 10.8.2?
     
  2. apedance macrumors member

    Joined:
    Sep 1, 2012
    Location:
    Vienna
    #2
  3. baxlobs, Dec 13, 2012
    Last edited: Dec 13, 2012

    baxlobs thread starter macrumors regular

    Joined:
    Nov 21, 2012
    Location:
    Suffolk UK
    #3
    The printer works fine from Windows, it also printed OK from my wife's iPad via HandyPrint installed on the iMac. I tried again this morning, and it printed one page OK, but when I tried it failed again after printing one page and the first line of the second. Curiously it ejected 3 pages the correct length of the document.

    I looked at the link you posted, but they want £35 to £40 depending on "detail" provided.

    I have looked in "console" it is pretty confusing for a Mac newbie, I could say a reference to printing, but there did not appear to be an error.
     
  4. apedance macrumors member

    Joined:
    Sep 1, 2012
    Location:
    Vienna
    #4
    forget this link. ;)

    ok. looks like a driver issue.

    i can just tell what i would do with this problem.


    Canon Pixma iP4600 right?

    (i) what driver are you running?
    did mac os x recommended a driver when you plugged in the printer? (i guess it is usb, isn't it?)

    (ii) what os x version are you using? (OSX 10.8.2, ...?)

    try reinstalling the driver.

    also try the driver provided here

    never install multiple drivers. always uninstall the old driver before you try a different one.
     
  5. baxlobs thread starter macrumors regular

    Joined:
    Nov 21, 2012
    Location:
    Suffolk UK
    #5
    Thanks for your reply, the problem is with the Laserjet, not the Canon which works just fine.

    I am currently engaged with Apple support to try and resolve this problem, which has turned out to be related to my User, the printer works OK with a different user!
     
  6. baxlobs thread starter macrumors regular

    Joined:
    Nov 21, 2012
    Location:
    Suffolk UK
    #6
    Thanks for all suggestions, as I said in my last post the problem was due to major problems with Users and Keychains. An online session with Apple support has (hopefully) resolved all the issues.:D
     
  7. apedance macrumors member

    Joined:
    Sep 1, 2012
    Location:
    Vienna
    #7
    oooooohhhhh.

    i thought canon ip4600 is the laserjet because you did not specify the laserjets manufacturer. hahahahaha

    anyways. good luck fixing your problem.

    cheers
     
  8. baxlobs thread starter macrumors regular

    Joined:
    Nov 21, 2012
    Location:
    Suffolk UK
    #8
    Further to this problem, even though my other problems appear to have been sorted by Apple support, this printer still does not work correctly. There is no duplex option, and it randomly misses pages from documents.

    I have installed Windows using Parallels, and looking at the printer there in Control Panel, although it is named "Laserjet 1022" the dialog shows it as a Colorjet series printer with entirely different options.

    I deleted this printer and added the Laserjet using the original Windows driver CD. Once setup it now can print duplex, and does not miss out pages. Result :D:D

    However it is still wrong on the iMac side. I am assuming because the iMac originally misidentified it as a Colorjet and installed the wrong drivers although it gave it the correct name.

    I thought if I deleted it in System preferences and reconnected it it might be correctly identified, but nothing happens and I need to Add it back again with new drivers, any idea how I manage to do this?
     
  9. baxlobs thread starter macrumors regular

    Joined:
    Nov 21, 2012
    Location:
    Suffolk UK
    #9
    Further update, I found that when I re-booted the iMac the printer was re-installed. However still with the wrong driver. :( Investigating in XP/Parallels I find that the iMac identifies the Laserjet 1022 as a Colorjet 8500PS with the appropriate options for that printer - presumably.

    This would explain why my Laserjet does not work properly.

    I have advised someone at Apple support of the problem. I can only hope that an answer can be found. There is obviously something badly wrong with the iMac's HP printer drivers.
     

Share This Page