Last attempt to fix my printer before I buy a new one

Discussion in 'Mac Accessories' started by Smileyguy, Jun 11, 2005.

  1. Smileyguy macrumors 6502

    Nov 29, 2004
    I really don't have any luck with printers. My last two have both gone bust. The one I'm using right now is a cheapo Epson Styls C44UX, I basically just want it for B&W text prniting.

    Thing is it hasn't worked for months. Now, I know very little about printers, but here's my best explanation of the problem:

    - The paper is loaded fine
    - The ink cartridge is not empty
    - I hook everything up, my Mac running OSX Panther recognises it fine. I open a word document and click print.
    - The printer makes a few noises like it is about the start, and then...nothing. That yellow button (the one that comes one when you're out of ink or there is paper jam) lights up and no matter how many times I press it, hold down on it, restart the printer etc..., nothing gives.

    That's a basic summary of the problem. I was going to order a new printer this morning, but I just thought I'd give it one more go. So if anyone can help me, please do!


  2. Artful Dodger macrumors 68020

    Artful Dodger

    May 28, 2004
    In a false sense of reality...My Mind!
    Hello, I feel your pain, I went through the same things with my HP (until I bought a new printer see sig). Anyway what does your print jobs say when this happens? My HP had to have it's name in the selection area "two" times before it would work and only half the time it did. Did you also get the latest driver from the Epson web site? Are you using AE with this printer or is it a direct feed into the usb port?
    I know it all sounds like you have done this but a friend of mine had a gum wrapper stuck in his printer (the foil) and it caused some trouble (yes he also said he cleaned it out :rolleyes: ).
    You said/did take out "all" the ink at once and cleaned the cart. as sometimes the chips can get extra ink and cause problems.
    If you can give some extra info. I'll try to help...I also own an Epson printer so I can look in it to see if it looks almost the same...
  3. Smileyguy thread starter macrumors 6502

    Nov 29, 2004
    Thanks for your help Artful Dodger, it is very much appreciated. I tried to download the latest driver, but when I do and try to open the install package I get an error message - "The installer package could not be opened - The Bill of Materials for this package was not found."

    The printer has a direct feed into the USB port. I will see now about print jobs, and try to double-print the page, as you suggest.

    I am pretty sure everything is fine and clean, but I will double-check.

    I'll report back when I have more answers.

    Thanks again. ;)

Share This Page