Late '05 PB G4 & wifi issues running OSX 10.5.8

Discussion in 'PowerPC Macs' started by joplinG5, Jan 30, 2014.

  1. joplinG5 macrumors member

    Joined:
    Jan 5, 2014
    #1
    Hi all,

    I have a late '05 PB G4 15" hi def that constantly drops its wifi connection when running 10.5.8 OSX. A few days ago I reverted back to 10.4.11 OSX and the PB G4 has connected flawlessly on wifi since. There's quite a few messages on the net about this and it seems to be a common problem especially with the PB G4 and 10.5 OSX... though many of the messages date back a few years. I tried most of the suggestions given by others in those posts to no avail.

    Has anyone heard about this and does anyone know if a fix was ever implemented? 10.4 OSX is fairly limited anymore and I'd like to get the wifi issues with 10.5 OSX resolved and go back to it.

    Thanks much!
     
  2. stroked Suspended

    stroked

    Joined:
    May 3, 2010
    #2
    Are you having a problem with a self assigned IP address?
    If so try this.

    Type the follow command first to access root control:

    sudo su

    then hit the return key

    It will then prompt you for your password. Enter your password and hit enter.

    then it should say something like "sh-3.2#" now type the following command

    ipfw flush

    then hit the return key - it will then ask you 'Are you sure' or something like that. simply hit the Y key. Thats it!

    Once you have done that, type in exit then hit the return key to exit out of root.

    then close out the terminal program.
     
  3. micahgartman macrumors member

    micahgartman

    Joined:
    Feb 22, 2005
    Location:
    Houston, TX, USA
    #3
    Are you using the built-in Airport card?

    Also, did you install Leopard over an existing Tiger installation?

    Did you update to 10.5.8 using a "combo" update?

    Do you like movies about gladiators?
     
  4. joplinG5 thread starter macrumors member

    Joined:
    Jan 5, 2014
    #4
    I gave this a go... but no change.

    I tried changing the router frequency again. Went from Ch 6 to Ch 1 with no improvement... then went to Ch 10 and has worked flawlessly since with full signal bars. Hopefully that did the trick.

    Still don't understand why wireless would work flawlessly under 10.4.11 with no changes needed... yet be very "picky" under 10.5.8. I've also never experienced a problem like this with my Windows machines.
     

Share This Page