Late 2006/early 2007 2.33 white screen on bootup

Discussion in 'MacBook Pro' started by LFCRules, Nov 4, 2012.

  1. LFCRules macrumors newbie

    Joined:
    May 19, 2008
    #1
    Hi

    Looks as if my MBP has finally given up the ghost. On bootup, get the apple icon as normal, and a flash of the screen, from black back to white and that's all she wrote. Hard drive works fine, have yanked it and booted from it on my mac mini fine.

    Can't get the laptop to boot via software CD, wont boot in to single user mode either, lion recovery partition won't boot up either. Every option I choose ends up with a whie screen and no cursor and no activity.

    Last time it was working I had the cursor with about 8 or so small horizontal lines behind it. Since have found this is similar issues with the NVidia problems with the MBPs which came out just after mine, mine is ATI Graphics.

    I assume it's a some sort of logic board error. Wll be taking it in to Southampton apple store next weekend to see what they say.

    Only good thing about this is that I'm getting a lot more use from my iPad 1 now with no laptop on the settee ;-)

    Will keep you in the loop with the rests on the store next week.

    Cheers

    Andy
     
  2. LFCRules thread starter macrumors newbie

    Joined:
    May 19, 2008
    #2
    Well that didn't take long. Went in to Apple Store in Southampton, and they diagnosed the usual logic board error with the graphics card being the culprit. So the normal NVidia problems hits ATI as well :(

    Took the east option out, and am typing on my new 15" MBP Non-Retina :D

    Getting used to all glass trackpad, but getting there.
     

Share This Page