Late 2007 Mac Pro no audio under Windows 7

Discussion in 'Mac Pro' started by chartier, Apr 25, 2009.

  1. chartier macrumors newbie

    chartier

    Joined:
    Dec 29, 2008
    Location:
    Chicago, IL
    #1
    I've tried installing Boot Camp from my Leopard DVD (Win 7 didn't like either of my mac pro's discs), installing the Boot Camp 2.1 update, and removing all audio devices and forcing Windows to search for new drivers.

    Anyone know what's going on? I was previously running Vista, but I heard games run better under Windows 7, and it was time to wipe the drive fresh anyway, so I thought I'd give it a shot. Any help so I don't have to roll back to Vista would be much appreciated.

    Update: This is even stranger. Turns out audio *is* working, but it is incredibly faint. I'm cranking volume up on my external speakers far beyond anything I would regularly listen to, and I can barely hear streaming music from sites like Lala or Last.fm. I checked the volume mixer and all my levels are up at 100, it's like there is some kind of extremely low audio level limit being enforced before it gets out to the hardware. Halp?
     
  2. Abidubi macrumors 6502

    Joined:
    Feb 13, 2009
    Location:
    Montreal
    #2
    I have no idea what your problem may be. I run windows 7 regularly on my 09 MP and it works flawlessly (by windows standards). I have no audio issues, no problems at all with the installation... Everything works. One thing I have noticed about windows though is it is horrible with multi-tasking compared to OSX. Sometimes it's smooth, sometimes you could swear it was 1999 and there was no such things as multi processing.
     
  3. Mrjynx macrumors member

    Joined:
    Aug 31, 2006
    Location:
    Toronto
    #3

    I have the exact same problem, mine is the first gen mac pro. Everything is set to max including my speakers and it's still fairly quiet. i can hear stuff, but by no means should everything be maxed out. In XP or OS X I would have blown my speakers by now.. I'm still trying to find proper drivers because I've been noticing my wireless card has to be reset quite often. I totally suck at searching so if anyone has any suggestions please let me know :)
     

Share This Page