Late 2008 15" MacBook Pro not detecting HDD

Discussion in 'MacBook Pro' started by 128keaton, Feb 14, 2015.

  1. 128keaton macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013
    #1
    Hey guys, I have a Late 2008 15" MacBook Pro that was working fine until one day, it wouldn't detect the HDD. I swapped the cable and now its still not working. Is the SATA controller shot?
     
  2. thebro20 macrumors regular

    Joined:
    Sep 7, 2014
    #2
    have you tested the HDD outside of the computer to see if it is just dead?
     
  3. 128keaton thread starter macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013
    #3
    Yeah, it works fine. I've even booted off of it with a USB SATA connector.
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    Unfortunately I would conclude it is, there is only the controller, cable and HDD.

    If you have swapped out the cable with a known good one and confirmed the HDD is good then there is only the controller left (plus a small possibility that you damaged the second cable installing it, sorry but had to mention).
     
  5. 128keaton thread starter macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013
    #5
    It would be kinda hard to damage the cable, nonetheless, I'm contacting powerbook medic (maybe they sent me a faulty one?) just to see if there is anything I can do
     
  6. 128keaton thread starter macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013
    #6
    I can see the SATA controller in 'System Profiler' , so I'm really thinking its the cable. Also, how do I get into AHT with this mac?
     
  7. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #7
    Just because the controller is visible to the system doesn't mean it is functioning properly.

    By all means replace the cable again if you have the means and/or doubt whether it is a known good cable, it is worth it given the impact of it being the controller and hence logic board.
     
  8. 128keaton thread starter macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013
    #8
    Good point, I'm trying to contact PBM right now, but we've had a 'snow apocalypse' which shuts down the south.
     
  9. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #9
    Stay safe...
     
  10. 128keaton thread starter macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013
    #10
    Thanks, its not bad, southerners see snow and assume death OR they rip out their 4x4 truck and think they are totally safe at 65MPH
     
  11. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #11
    LOL - Uk just shuts down completely. I'm now in Auckland, next to no snow here, ever...
     
  12. 128keaton thread starter macrumors 68020

    128keaton

    Joined:
    Jan 13, 2013
    #12
    Anyway, PowerbookMedic will be swapping the part out post-haste, I just need to get to the postal.
     

Share This Page