Resolved Late 2008 MacBook wakes from sleep by itself

Discussion in 'MacBook' started by israelmunoz, Nov 23, 2012.

  1. israelmunoz, Nov 23, 2012
    Last edited: Dec 2, 2012

    israelmunoz macrumors newbie

    Joined:
    Nov 23, 2012
    #1
    Hi guys,
    Although I just registered, I've been wandering these forums for quite some time now, however, just recently, needed some help...

    I got a friend's Late 2008 unibody Macbook, which had 10.5.8. She wanted some help on making a Time Machine backup, and install 10.8.

    I got her laptop, did the backup, installed a fresh copy of 10.8, installed the updates, and everything looked great, but before I continued with the installation of the other stuff, or transferring her files, I closed the lid, and went on to do some stuff.

    Came back to an empty battery... Then, doing some further tests, it turns out, the macbook wasn't sleeping properly. When I close the lid, it sleeps, and then immediately wakes up, same thing happens if I put it to sleep from the drop down menu with the lid open.

    I googled a bit and found this link: http://osxdaily.com/2010/07/17/why-mac-wakes-from-sleep/
    Turns out it's waking up with reason: OHC1. The curious part is, there is nothing USB attached...

    From what she told me, it didn't do that before, but it is right now.
    I'm a bit baffled, and would love some help...

    Any suggestions as to what to look for next?

    Thank you so much for your kind help!!
     
  2. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #2
    Ok, another thing, I'm trying to reset the PRAM and I just can't!

    Whenever I try it, it takes me to the OSX Utilities!!!!

    :(

    Reseting the SMC didn't do the trick :confused:
     
  3. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #3
    What does the Console display when this happens?
     
  4. israelmunoz, Nov 24, 2012
    Last edited: Nov 25, 2012

    israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #4

    That's an excerpt of the console, from when it started showing things related to asking it to sleep from the menu.

    Thank you!!!!
     
  5. ryrzy macrumors newbie

    Joined:
    Nov 24, 2012
    #5
    Try disabling bluetooth and AirPort before going to sleep. Also, try going to the sleep option in the apple bar instead of closing the lid. There might be something interfering with the display magnet causing it to wake up.
     
  6. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #6
    Thank you for your input, I always had bluetooth disabled, but I'll try some tests.

    Tests:
    Sleeping from menu:
    Bluetooth ON; Airport ON: Wakes immediately after sleep.
    Bluetooth OFF; Airport ON: Wakes immediately after sleep.
    Bluetooth OFF; Airport OFF: Wakes immediately after sleep.

    Sleeping with lid:
    Bluetooth ON; Airport ON: Wakes immediately after sleep.
    Bluetooth OFF; Airport ON: Wakes immediately after sleep.
    Bluetooth OFF; Airport OFF: Wakes immediately after sleep.

    Would it help if I provide the console output from any of those tests?

    EDIT: Tried the exact same tests but without it being connected to the AC power, to no avail.

    Again, thank you very much!! ANY help is appreciated!
     
  7. tug, Nov 25, 2012
    Last edited: Nov 25, 2012

    tug macrumors 6502

    Joined:
    Feb 3, 2010
    Location:
    loughborough. u.k.
    #7
    have you looked in sys. prefs. energy saver. there might be something in there that might be making the mac wake immediately, check in the schedule also. good luck.
    ps. you hav'nt got caffeine installed by any chance?
     
  8. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #8
    Could you go to Console, hit "Clear Display", shut the lid, open, and copy what it outputs?

    PS- Disable smilies- it was putting them into the console!
     
  9. israelmunoz, Nov 25, 2012
    Last edited: Nov 25, 2012

    israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #9
    Hi! The computer was formatted and a new unaltered copy of OSX 10.8 was installed, after that, ONLY the updates were installed, taking it to 10.8.2, no settings have been changed whatsoever.
    However, I did look into the system preferences, and from what I could figure out, there's nothing there that would make it wake up immediately. Should I be looking into anything specifically?

    Thank you!

    ----------

    Ready, I hit "Clear Display", closed the lid, waited until it woke up (not even 1/3 of a second after it fell asleep), opened the lid, and copied the new info.

    I disabled smilies this time, and thank you for taking your time to come back and further assist me!

    PS. If it is of any help, Bluetooth was disabled, but WiFi was enabled and logged into my wireless network.

    Here's the output from Terminal when I gave it the command:
    syslog |grep -i "Wake reason"
     
  10. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #11

    Thank you, I checked that webpage already.
    Here's the output from Terminal when I gave it the command:
    syslog |grep -i "Wake reason"

    However, there's nothing USB attached...

    I think I'll try to get the 10.5 DVD it came with and install that, see if the problem can be replicated there.

    Thank you all!
     
  11. mwhities macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #12
    Disable (uncheck) "Wake for network access" in System Preferences > Energy Saver?
     
  12. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #13
    I noticed that it's only on the tab for AC power, right?
    Anyways, it was already disabled... :(

    I'm really desperate, and she hasn't (and most probably won't) find the 10.5 DVD :(
     
  13. mwhities macrumors 6502a

    Joined:
    Jul 13, 2011
    Location:
    Mississippi
    #14
    Sorry, I am of no help past that.

    Good luck.
     
  14. ryrzy macrumors newbie

    Joined:
    Nov 24, 2012
    #15
    Hmm, try running this command, and posting the output:

    pmset -g assertions
     
  15. israelmunoz, Nov 27, 2012
    Last edited: Nov 27, 2012

    israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #16
    I appreciate the help nevertheless!!!

    ----------

    Thanks, I'm arriving to work now, so I'll try that in 9 hours when I come back.


    On another topic, I read through the console output yet again, and it struck me that I hadn't noticed that it says that the keyboard/trackpad is waking it up.

    I looked for a stuck key by opening the onscreen keyboard, and going to TextEdit and trying to see if any key behaved weirdly.
    Turns out that the left and right arrow do not work... So I'm starting to consider a malfunctioning keyboard...

    I'll try what you're telling me, and if that takes us nowhere, I'll disassemble it and try to sleep it without the keyboard connected.

    Anyways, thank you all! Be back in 9 hours... :eek:
     
  16. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #17

    There it is!
    Sorry for the delay, but I had a very full week, only coming back to this today now!


    If it is of any help, the left and right arrow DO NOT function...
     
  17. ryrzy macrumors newbie

    Joined:
    Nov 24, 2012
    #18
    Try running this command and see if it sleeps:

    launchctl unload -w /System/Library/LaunchAgents/com.apple.helpd.plist
     
  18. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #19
    That didn't change anything :(

    I'm suspecting the keyboard, which functions just perfectly, except for being quite dirty (my friend used to eat in front of her macbook ALL the time), and having non functioning left and right arrows.

    I'mma disassemble the macbook and disconnect the keyboard, and try again, and see how that works.

    Thanks!!!
     
  19. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #20
    ha.... pinpointed the problem...

    When I disconnect the keyboard ribbon cable, the sleep functionality works perfectly again...

    By the way, if anyone reading this ever wants to turn on their A1278 macbook without the keyboard (power button is in the keyboard) you just need to short the 5th and 6th pin of the keyboard connector on the motherboard.
    source: http://www.ifixit.com/Answers/View/48232/How+to+connect+power+button+directly+to+logic+board

    Gonna try and clean the keyboard, and see if I can fix it without changing it, as it is a VERY expensive piece of hardware :(


    Anyhow, thank you ALL very very much for your kind and patient help.
    I'm very thankful, and I'll try to give back to the community by offering my limited knowledge of computers on these forums more often!

    ----------

    By the way, what did this do?
    Should I set anything back to normal, considering the problem lies on the keyboard?

    Thank you!
     
  20. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #21
    Considering a good clean of the keyboard did not fix the issue, how possible is it to block the keyboard from waking up the mac?

    I've googled to no avail. Any insight on this would be awesome!
     
  21. israelmunoz thread starter macrumors newbie

    Joined:
    Nov 23, 2012
    #22

    Ok, I did find a solution, but it no longer sleeps... I changed the Power Management settings through the console with the command:

    Now, the computer hibernates instead of sleeping, whenever I close the lid, press Command+Option+Eject or through the Apple menu.

    It does take longer, and a clic on the power button to come back to life, BUT, I no longer need to change the keyboard to have a functional laptop again.

    THANK YOU ALL for your kind input!!

    It was a nice journey and I learned a lot of new things :D

    See y'all around :p
     
  22. ryrzy macrumors newbie

    Joined:
    Nov 24, 2012
    #23
    Congrats that you got your problem solved!

    That was disabling the process from the pmset command.
    To reverse the command, just run this:

    launchctl load -w /System/Library/LaunchAgents/com.apple.helpd.plist
     

Share This Page