Late 2009 27" Hard Drive failing & replaced, can't make Genius Bar data recovery work

Discussion in 'iMac' started by ehulden, Apr 28, 2015.

  1. ehulden macrumors newbie

    Joined:
    Apr 26, 2015
    #1
    Hello and thank you for reading my post! I'm sorry it is so long, but I tried everything I could think of before bothering you kind folks. . .

    I have a late 2009 27" iMac and my 1TB Seagate hard drive was failing. I took it to the Apple Genius Bar for diagnostics and was told I'd need a new hard drive but as my 1 TB memory was almost full my external hard drive with Time Machine hadn't done an update since 12/31/2014. He helped me transfer several files from my desktop and documents to fill the tiny bit of empty space on my external hard drive. As he recommended, I chose to purchase a 3TB hard drive online and have Simply Mac install it for me. He also told me to buy a hard drive enclosure to salvage the data that there wasn't room for on external hard drive.

    The Time Machine loaded fine and I was able to transfer those files he put on there in addition. So I'm sitting here, not as tech savvy as I'd like to be, trying to follow the very simple seeming steps he used to transfer the remaining files from my Seagate 1TB hard drive now in its new Sabrent Hard Drive enclosure and either my hard drive is a total loss now or I'm missing a step from what I recorded from my Genius friend. Here are my notes:

    "From Finder to the Go drop down, press alt/option to select Library. Go to your user account and type your user account name in with "/Library" behind it, then application support, then drag and drop."

    I can get to the library no problem, but I can't figure out where to type in the username account/Library as the only text box is to search and it didn't find anything when I tried that.

    I tried to go through Migration Assistant, but it just searches and searches and the hard drive doesn't come up, even searching it by username account, username account/Library, or Macintosh HD (which is the name of the drive as it pops up on my screen when I've got the drive plugged in by USB cable.)

    I also tried to go in to the Macintosh HD icon and although I can't find my GarageSale files (which is the most important as I am an eBay seller and have had very, very little business while I've been repairing all this) I was able to find my iPhoto pictures files, but it says I only have read access and despite the username account title being the same, the password being the same (for now), and the OS X versions being the same it won't grant me access.

    Please help me save my GarageSale files and photo library since New Years if you can. It looked like a cool breeze watching the Genius Bar guy do it. Why can't I make it work?

    Thank you for reading this and any advice you can offer. Have a wonderful day!
     
  2. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #2
    Migration Assisstant

    Is it just Migration Assistant where you can't see the drive? Can you still browse it through Finder? If the drive's completely died now, wrap it in a couple of plastic bags and put it in the freezer for a day. When you get it out again, it MIGHT revive itself just long enough to copy some more files off.


    GarageSale

    Your notes seem a bit confused. In Finder, go in to the Go menu and click on "Go to Folder..." (near the bottom). Then type exactly this:
    Code:
    ~/Library/Application Support
    That should open the Application Support folder on your machine. On the old hard drive, you need to go into these folders:
    Code:
    Users -> [username] -> Library -> Application Support
    In there, there should be a GarageSales folder. Copy this straight into the other Application Support folder.


    iPhoto

    Select your photo library and press cmd+I. You should get a window like the attached screenshot. Click the gold padlock and give it your username/password. Then, in the Sharings & Permissions section, click next to your username and change "Read only" to "Read & Write".
     

    Attached Files:

    • ss.png
      ss.png
      File size:
      63.3 KB
      Views:
      28
  3. ehulden thread starter macrumors newbie

    Joined:
    Apr 26, 2015
    #3
    Hello and thank you very much for your valuable advice. I haven't been able to make it work, but perhaps you can give me insight into why it isn't working. I hope the following is coherent. Please let me know if I'm not getting my steps and results across.

    When I have the hard drive plugged in, I can click the icon and see four options: Applications, Library, System, & Users. Applications has GarageSale, but clicking it only opens the program with only the data from the Time Machine back up, not any of the missing data from the hard drive. Library and System don't list GarageSale, and in Users (the steps you recommended) Library shows up under Guest, but not under my user name, and the following Application Support folder seems to contain nothing. Under my user name, there is no Library but an Application folder which also seems to have no contents.

    iPhoto and general hard drive weirdness: I had seen a similar screen to the screen shot you provided when I went into the Macintosh HD info and for Sharing and Permissions it says "You can only read" then lists my user name and says the privilege is read & write, then staff and everyone are Read only. I can unlock the padlock with my password, but it won't do anything when I click Privilege and will only let me check and uncheck a box that says "Ignore ownership on this volume" but seems to do nothing but change where it says my user name, staff, everyone to system, wheel, and everyone, but I still didn't have any luck accessing the info with that change made.

    For iPhoto I opened info as you suggested and it says user name, staff, and everyone have read & write access to iPhoto, but when I try to open it, it still says I don't have enough access.

    I have a theory that part of the problem is that the user name on my computer with the Time Machine back up is the same as the user name on the Macintosh HD (which makes sense considering one is only a three month older version of the same thing) and that it's either thinking that the two entities are different: such as saying I only have read access directly above where it shows that my user name has read & write access on the hard drive, or it's thinking the two are the same but not giving me access for a different reason. The system password is the same for both but I'm not sure what the impact would be if it wasn't. Now I'm not sure if changing the user name or password (which I assume is possible but haven't pursued) would make the problem better instead of worse.

    Any suggestions or illuminations from the results I am having?

    Thank you so much for taking the time to help me, I truly appreciate it!
     
  4. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #4
    I've just had a look at my own Time Machine backup. Surprisingly, the user library is a hidden folder in there as well.

    Press cmd+shift+U in Finder to open your local utilities folder. Find Terminal and drag it on to your dock. Now go back to your external hard drive and drag your user folder (the folder named after your user) on to the Terminal icon on your dock. A white Terminal window should pop up. Type:
    Code:
    open Library
    and hit enter. Your old user library folder should open. Carry on and look in Application Support for the GarageSales folder.

    Two things to try:
    1. Press cmd+I on your iPhoto library again. Make sure that the "Locked" checkbox is unchecked at the bottom of the "General" section.
    2. Right at the bottom of "Sharing and Permissions" is a little cog wheel. Click it and then click "Apply to enclosed items..." You may need to click the padlock again first.
    If those don't work, can you copy and paste the error message you get when you open it?

    Permissions can start getting complicated when you throw in external drives and network shares, but no - if it says your username, it does mean you on that computer.

    If you press cmd+I on the hard drive and check under the General section, what does it say for format? I can't think of many obvious reasons off the top of my head why this would happen.
     
  5. ehulden thread starter macrumors newbie

    Joined:
    Apr 26, 2015
    #5
    Wow, thank you for your quick response!

    I went to follow your instructions in order, and unfortunately when I entered "open Library" I got that it failed "error -5000". I tried twice to no avail. Now, when I go in to the hard drive there are little red minus symbols on all the folders and they all seem to be empty! The size of each folder even says "--"! I did have the exact error message copied, but this website blinked out for a moment and reloaded with a blank reply screen so I am certain the error was -5000, but don't have the exact additional phrasing. If you need it, I can try again, but with all the folder weirdness, I'm a bit hesitant.

    So I couldn't get to iPhoto to try your second set of instructions.

    I did follow to the end and under General in my Macintosh HS Info it says Mac OS Extended.

    Thank you so much!
     
  6. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #6
    If you haven't already, try unplugging the hard drive, rebooting your computer, and plugging it back in. If you still can't open the folders, press cmd+I on the hard drive and see what's going on in permissions.

    Ah, sorry, I assumed you'd copied the library across to your local computer. If you get the chance, do this before you do anything else.

    Yeah, that's what it should be. Just thought it was worth checking.
     
  7. ehulden thread starter macrumors newbie

    Joined:
    Apr 26, 2015
    #7
    Good news! I was able to follow your instructions and transfer the GarageSale data and it seems present and accurate, yay!

    I'm still struggling with the less important, but still wanted picture files in iPhoto. I tried to follow similar steps to what I did for GarageSale, but couldn't find anything like what I wanted. Even locating iPhoto Library on the Macintosh HD just opened up iPhoto with only the files prior to 1/1/15. It doesn't seem to have files like other applications have and doesn't even seem featured in Application Support. I did command i specifically on iPhoto Library (which says it's most recent update is April 6th which was right before the crash) and the Sharing and Permissions specific to that seem to say that all three choices all have read & write access, but when trying to move it off the HD, it just says "Caution The iPhoto Library is on a locked volume. Relaunch iPhoto when the volume has read/write access or relaunch iPhoto with <option> key held down to choose another library" and only gives me the option to Quit.

    Any ideas how I can even get to what I want to transfer because as far as iPhoto goes, I haven't even gotten that far yet.

    I truly appreciate all of your help. Getting the GarageSale stuff transferred means I can get back to work. Thank you so very much!
     
  8. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #8
    Great!

    This is the only file that you need. iPhoto stores all of its data inside "iPhoto Library", so you just need that one (large) file. There isn't anything in Application Support that you need to grab.

    It sounds like you're trying to open the iPhoto Library from your old hard drive (possibly unintentionally, if iPhoto's decided that's the library it's using).

    Drag and drop the iPhoto Library file to your desktop. It might take a while to copy. Then hold down the option (alt) key and click on iPhoto in your dock. It should ask if you want to choose a library to open. Say 'yes' or 'choose' or whatever and navigate to the file on your desktop. Hopefully it'll open then. If it complains about permissions, press cmd+i on it, make sure your username is there with "read and write" and try again. If your username isn't there, press the plus button underneath the list to add it.
     
  9. ruisamuel123 macrumors newbie

    Joined:
    May 25, 2015
    #9
    external hd don´t work

    HELLO i have a very strange problem in my hdata hd710... i use it like a external hd in my imac .... the think is ...last week the hd disapear ...don´t shows in the imac... just in disk utility but i can´t repair , i can´t mount,nothing ...i try in my macbook and is the same ... i try with disk warrior and the disk don´t apear ...i can´t see it there,,,,same with another similar programs like data rescue drive genius... i can´t see it there... and all the time i put the hd show me the error message...*the disk you inserted was not readable by this computer mac* now i don´t care about the hd i just want the files... but its so difficult cause i try so many thinks.... somebody can help me ? thanks
     
  10. 0d085d macrumors regular

    Joined:
    Apr 23, 2015
    #10
    You will have better luck if you make a new post in this forum, as more people will see it.

    Plug the hard drive in to your computer. Open the Terminal application and type
    Code:
    diskutil list
    Hit enter and paste the output into your post as well. That may help show what is going on.
     
  11. ruisamuel123 macrumors newbie

    Joined:
    May 25, 2015
    #11
     

Share This Page