Late 2009 iMac: Bluetooth no longer in System Preferences

Discussion in 'OS X Mountain Lion (10.8)' started by HawaiiMacAddict, Jul 25, 2012.

  1. HawaiiMacAddict macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #1
    Aloha everyone,

    I don't know if I'm in the very small majority, but I installed Mountain Lion on my late 2009 iMac this morning and experienced what I consider to be a huge issue. After the reboot, I could only use my magic trackpad as a simple one-button mouse. The Bluetooth icon in the menu bar reported that Bluetooth was not available, and the Bluetooth section in System Preferences is no longer there. Short of a "nuke and pave", what should I do?

    I'm at work now and my iMac is at home, so I'll tackle this once I go home. I was thinking that a simple reboot may do the trick, but I can't figure out why the Bluetooth section would simply not be in System Preferences anymore. It's not as if I intentionally deleted it. What's more puzzling is that I know I have Bluetooth connectivity - after all, I use a Bluetooth keyboard and magic trackpad with my iMac. I would appreciate any ideas, suggestions, etc... from the community here at large. I really don't want to do a "nuke and pave".
     
  2. pamartel macrumors newbie

    Joined:
    Jul 25, 2012
  3. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #3
    Probably a corrupt plist.

    Go to /HDD/Library/Preference an delete (move to trash) any and all files called com.apple.Bluetooth.plist, com.apple.Bluetooth.plist.lockfile and com.apple.Bluetooth.plist~orig

    Don't empty you trash though incase you still need them

    Restart your Mac and see if it fixes it

    Also try repairing permissions.
     
  4. ugp macrumors 65816

    ugp

    Joined:
    Jan 7, 2008
    Location:
    Inverness, Florida
    #4
    I did not encounter this problem. Mine is present.
     
  5. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #5
    It seems to be working just fine on my wife's late '09 iMac.
     

    Attached Files:

  6. Exotic-Car Man, Jul 25, 2012
    Last edited: Jul 25, 2012

    Exotic-Car Man macrumors regular

    Exotic-Car Man

    Joined:
    Oct 29, 2010
    Location:
    USA
    #6
    ML vs. Lion System Prefs

    Thanks to your screenshot, I was able to create a Mountain Lion vs. Lion System Preferences. ML is on the left; Lion is on the right.
     

    Attached Files:

  7. HawaiiMacAddict thread starter macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #7
    Thanks much daneoni! That did the trick (the first thing - I haven't yet repaired permissions). I can now use gestures again! I actually forgot about CTL-click for the right-click context menu for a while. D'oh! Anyway, thanks again for the tip.
     
  8. KwaiChangCaine macrumors newbie

    Joined:
    Dec 20, 2012
    #8
    same problem

    I dont have the com.apple.Bluetooth.plist~orig on my preference folder
    thanks
     
  9. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #9
    You don't have to have all three...
     

Share This Page