Late 2011 MBP Doesn't See Charger?

Discussion in 'MacBook Pro' started by Ansah, Aug 10, 2015.

  1. Ansah macrumors newbie

    Ansah

    Joined:
    Sep 27, 2011
    #1
    Hi,

    A friend asked me to take a look at his late 2011 MBP, i7, 8GB. It does not recognize the charger. I ran the Apple Hardware Test (several times) and got this error:

    4SNS/1/40000001: VP0R-0.000

    This seems to have to to with a voltage/sensor/power buss issue...

    If I remove the bottom plate and disconnect the battery and (sometimes) remove one of the memory sticks, the charger is instantly recognized... So I was able to recharge the battery and it seemed to work fine. But once the charger is disconnected it becomes unrecognizable again.

    I've tried the usual stuff, NVRAM and SMC resets. I have tried three different chargers that work on other machines. He says he only wants to fix this if the fix is relatively cheap. If he has to buy a whole new logic board then he'd prefer to sell it for parts and buy new.

    Any ideas? Thanks.
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Replacing the logic board may be needed, but you may want to try out cheaper options.
    For example, the magsafe board won't be very expensive (maybe < $25), and not too tough to replace. It MAY fix the problem, and would be worth trying.
     
  3. LiquidSpikes macrumors regular

    LiquidSpikes

    Joined:
    Jul 6, 2007
    Location:
    Everett, WA
    #3
    My MBP 2011 stopped charging once about a year ago, it was just really worn and dirty. I took a old toothbrush and put some Windex on it, and scrubbed the macport, cleaned it up really nice and has charged fine ever since. :) best of luck!
     

Share This Page