Late 2011 MBP Trackpad Fail

Discussion in 'MacBook Pro' started by portcontrol7, Apr 17, 2012.

  1. portcontrol7 macrumors member

    Joined:
    Aug 28, 2011
    #1
    So yesterday I decided to enable the "tap to click" feature in my trackpad settings. <Awesome> I now prefer the light tap to the hard click by far. </Awesome>

    <Suck> After a reboot today, I noticed I could not tap on my username to login. Tried hard clicking and nothing as well. So then I figure out I need to use the arrow keys and hit enter and then enter my password. Same goes for the recovery console, neither hard clicking nor tapping works. </Suck>

    <Incredible Suck> So after logging in, I disable the "tap to click" feature. Now I can no longer tap of course, but worst of all hard clicking the trackpad doesn't work either!! So I tab into the "tap to click" feature, hit spacebar to enable the feature again, and experiment. Again tap clicking works beautifully. Hard clicking no longer works, but SOMETIMES works after rapidly hard clicking something, say a folder. </Incredible Suck>

    I called Apple and the tech said I should bring it in and/or reinstall Lion. Just got done reinstalling Lion (awesome 4 hour internet ins all btw) and the problem remains. Hard clicking come back!!! And what are the odds it was a hardware failure? I would say slim to none. Please help good ladies and gentlemen.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    It might probably not help, but does it also happen in another, even temporarily created, user account?

    And for later purposes, you can use the Lion Recovery Disk Assistant to make an installer on an external HDD or USB flash memory thumb drive, if you don't have a Lion Recovery partition.

    OS X Lion: About Lion Recovery
    Lion Recovery Disk Assistant
     
  3. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #3
    I would have said the chances of me going through 4 original iPhones before I got one that worked would have been slim to none...before it happened to me. If the reinstall didn't do anything I'd take it in unless it's transportation prohibitive.
     
  4. portcontrol7 thread starter macrumors member

    Joined:
    Aug 28, 2011
    #4
    Well I didn't try it with another account, but I did a fresh install of Lion and that didn't solve it. So after some digging around on the net, I found something that embarrassingly works:

    Click the living **** out of the trackpad in rapid succession! Strangely, it now accepts both a light tap, and a firm click with no issues. I don't DARE change the trackpad setting by taking OFF the setting. Actually, you know what? I do DARE... brb. Okay back...

    Took the tap to click setting OFF. And I wil be hard-clicking submit, if nothing further posted, it now works fine.

    ----------

    Well obviously it did work. I turned the "tap to click" setting back on again, and both types of clicks (tap and hard click) work fine. Buggy, but I'm satisfied with the solution. Sort of like kicking the TV to get it to work, but I am still convinced it is a software issue that rapid clicking solved by somehow allowing the trackpad to "know" I mean to click and not merely tap, like a buggy handoff between clicking modes.

    :) Hard-clicked
    :) Tapped

    :confused: but :D
     
  5. ixodes macrumors 601

    ixodes

    Joined:
    Jan 11, 2012
    Location:
    Pacific Coast, USA
    #5
    I have a 15" MBP that I purchased online via the Apple store in December. All was well until I too, experienced what seems to be exactly the same issue you had. After monitoring the situation for five days, I cleared some time so as to work on the problem.

    I installed Lion on a USB Flash drive and performed a clean install. In my case that took care of the problem. It's been over a month now, and the issue has not returned. Just thought I'd report what worked for me in case others are experiencing this same situation.
     

Share This Page