Late 2012 m-mini will not complete reboot cycle by itself

Discussion in 'Mac mini' started by Jamesehale, Nov 2, 2016.

  1. Jamesehale macrumors newbie

    Joined:
    Dec 15, 2011
    Location:
    Australia
    #1
    i have a late 2012 mini as my local server. Since purchasing it there has been only one persistent problem.
    Whenever it needs to go through a restart/reboot cycle it gets stuck and needs to be forced off, by holding down the power button and then restarted.
    Granted I do not need to do this often, mainly with OS upgrades or some driver installs for my drobo but it really bothers me.
    The sequence during an upgrade is fine until after initiating the restart, the screen then goes blank, the restart chime is heard and then...nothing. It just sits there with a blank screen. Power is on to all devices (including the screen), no hard disk activity, just a powered brick. If I then press and hold the power button it turns off. I then press,the power button again, it turns on and completes the install.
    I have tried a safe reboot (didn't reveal anything), upgraded the RAM, changed from the internal drive to boot from an external SSD. Nothing seems to make any difference.

    Has anyone else had this issue?
    Has anyone else solved this issue'?
    Does anyone else know what the hell is going on?
     
  2. for this macrumors regular

    Joined:
    Nov 18, 2014
    #2
    IME, this kind of problem is related to USB. Try unplugging all USB devices then restart, just to confirm if it's USB or not.
     
  3. Jamesehale thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    Location:
    Australia
    #3
    This will need to wait until w/e but I have my doubts.
    For quite a while, until I transitioned to the external SSD boot drive, the only USB device plugged in was an Apple keyboard.
     
  4. 1411 macrumors newbie

    1411

    Joined:
    Jan 15, 2016
    #4

    I too have had this problem, not once but twice on two different late "Maverick" 12 minis!! Called Apple, they said logic board is bad......but all of a sudden on two separate Minis within a month. Reloaded Time-Machine BU from June and so far so good. Apple must have done something in an update somewhere? Also could be memory related as it happened to second mini after swapping out the 8GB with 16Gb i had in the the first one. Also I did have issues with a USB3 external boot drive which didn't work at all.
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    Next time you need to reboot or shutdown, try this (can only be done "manually"):

    a. DO NOT choose "shut down" or "restart" from the menu
    b. Instead, choose to LOG OUT
    c. When you get to the "log in" screen, there are icons below to shut down or restart
    d. Click either one, depending on what you wish to do.
    e. What happens now?
     
  6. Jamesehale thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    Location:
    Australia
    #6
    It is bizarre how hearing of another having the same problem is comforting even when, rationally you would prefer if they didn't.
     
  7. Jamesehale thread starter macrumors newbie

    Joined:
    Dec 15, 2011
    Location:
    Australia
    #7
    SOLVED!
    Well first I tried the restart after logging out trick - didn't work.
    So OK let me remove the USB connections and see what hap[pens.
    As I looked at what I did have connected I noticed a rather older (beige) USB cable and wondered what I had connected to this. Anyway I removed all cables except the external boot drive's one and rebooted. Worked.
    Added the keyboard, selected restart, and it worked!
    Hmm, what is this beige cable for? Turns out I had it connected to a Belkin UPS. OK I thought, perhaps an update to a driver? Went to Belkin's site (local and US) and discovered they no longer made these babies.
    So I will leave out the UPS connection (given it is unlikely it works anyway), maybe check out a new UPS (mine are a tad old) and enjoy a mini that will now reboot.

    So I will conclude it was indeed a USB connection.

    Thanks to all who offered an opinion.
     

Share This Page