Late 2012 Mac Mini - super slow wifi

Discussion in 'Mac mini' started by Agrajagg42, Aug 14, 2015.

  1. Agrajagg42 macrumors newbie

    Joined:
    Aug 14, 2015
    #1
    I have a Mac Mini (late 2012) 2.3 i7 w 16 gig of ram that is seeing super slow wifi speeds.

    I've run several speed tests on a couple of other Windows PCs i have in my house connected wirelessly to the same router which are 5-7 times faster than on my mac.

    I'm seeing DL speeds on my Mini of only 5Mbits, where I'm getting 33Mbits on my Acer laptop, and 22 Mbits on my Dell Laptop (which is 6 years old) and is sitting right next to my Mac Mini.

    interestingly, I'm getting 10Mbits+ upload speeds on ALL three machines (the Mini included).

    I've tried shutting down the laptop which is in close proximity to the Mac Mini (incase it was causing interference) w no effect. I have read that USB 3.0 HDDs next to the machine can cause issue (which is crazy, but true), and i've made sure those are off... I've shut off and restarted my wifi adaptor - and it's still crazy slow... Any thoughts?

    Thanks!
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Can you connect the Mini to your router via ethernet?

    And test it that way?
     
  3. Agrajagg42 thread starter macrumors newbie

    Joined:
    Aug 14, 2015
    #3
    The router is on the second floor, in the bed room where the cable comes into the building, it's also positioned the center of the house, in hopes of providing the most coverage at both ends of the building, connecting to Gbit eNet is not feasible w/o snaking Cat5e/6 cable through the house (which I HAVE been tempted to do, but... haven't). (I have a spool out in the shed)

    There IS another other cable demark point which IS in the same room with the Mac Mini, but now and add'l 40 - 50 feet from and that will affect WL reception in the Kitchen on my laptop (which frankly I use more often)... I guess I could get a WL repeater.

    But what I don't understand is why the 6 year old PC Laptop next to my mini can pull down 20 MB and this mini is only seeing 5, but BOTH are getting 10 MB upload.

    Add'l piece of info, the WL icon in the status bar is showing FULL bars...

    Weirder and weirder...
     
  4. Negritude macrumors 6502

    Joined:
    Jul 14, 2011
  5. Agrajagg42 thread starter macrumors newbie

    Joined:
    Aug 14, 2015
    #5
    OS 10.10.2

    Just did a fresh start up from a complete shut down, only 6.2 Mbit down, and suddenly on 2Mbit up... GRRR
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    I suggest you update your OS to either 10.10.4 or 10.10.5 ...
     
  7. marclondon macrumors regular

    Joined:
    Aug 14, 2009
    Location:
    London
    #7
    Also there's a firmware update for the 2012 Mini.
     
  8. campyguy macrumors 68030

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #8
    OP, you failed to mention which router make/model you're using. I've a 2012 Mini Server sitting about 2 feet from my late-2013 rMBP - they're both connected via wifi to the same AC Extreme, and sometimes my Mini Server's speeds tank. I've found that 90% of the time the Mini Server didn't "see" the 5GHz network and connected to the 2.4GHz network - objects like a fan, solid object, portable drive, or unshielded USB cable between the AC Extreme and the Mini Server would disconnect my Mini Server from the 5GHz network and cut my wifi speeds significantly - borne out by removing the impediment and reselecting the 5GHz network. I also have a 4th-Gen Extreme and a Mini Server in another of my offices and have identical conflicts there. FYI.
     

Share This Page