Late 2012 Mini USB port question

Discussion in 'Mac mini' started by Wie Gehts, Jun 1, 2018.

  1. Wie Gehts macrumors 6502

    Joined:
    Mar 22, 2007
    #1
    I'm curious. Is there any sort of heirarchy of importance regarding a late 2012's 4 usb ports, or are they all exactly the same in functioning?

    For example, would there be a preferred port to use with, say, an audio interface as opposed to which port you'd plug your keyboard into?

    Thanks
     
  2. Celerondon macrumors 6502a

    Celerondon

    Joined:
    Oct 17, 2013
    Location:
    Southern Cal
    #2
    Nope, those four ports are all the same. You do have to be careful if you also use USB 2.0 devices with your ports. https://support.apple.com/en-us/HT201163
     
  3. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #3
    The linked article says:

    How do I get the best performance from the USB 3 ports?
    The first device you plug in will configure the port, so always connect USB 3-capable hubs or devices first.

    What happens if I plug in a USB 2 device into the USB 3 port first?
    If you plug in a USB 2 hub first, all devices connected or "daisy-chained" to that hub will operate up to the maximum transfer rate of USB 2 speed (480 Mbps).

    Which doesn't make much sense if you always have different USB types always connected to your computer. Which one is the first at power-up or restart? The second question/answer is confusing. If you have a USB2 hub, you'll get USB2 speeds max on the connected devices - nothing revelatory about that. Now, there is an internal "hub" that shows up (at least on 2012 Mini) under the USB 2.0 Bus tree in the System Information app. Is that the "hub" that's being referred to in the 2nd question? I'm just confused with what they're trying to say.

    I don't know if this article applies to only Macs with the USB-C port or all Macs with USB3. In my experience on my Macs (don't have one with a USB-C port), it didn't seem to matter. So I tried this on both my 2012 and 2014 Mini's: Started the Mini with only the USB keyboard (with attached mouse) plugged in. Then, connected a USB2 external drive. Then, connected a USB3 external drive. The USB3 drive shows USB3 speeds, both in the System Information app and with the Blackmagic Disk benchmark. Then, on the 2012 Mini, tried in turn a USB2 and USB3 flash drive - nothing unusual - they showed as they're supposed to in the System Information app.

    With regards to the OP's question, with the 2012 Mini, if you run the System Information app (under Hardware->USB), you'll find that devices you connect to the 4 USB3 ports show up under the "USB 3.0 Bus", regardless if it's USB2 or USB3 or a keyboard. You can see what effect plugging in a device has on the device tree. After plugging or un-plugging a device, you need to do File->Refresh (Cmd-R).

    Sometime ago I did a test with a USB2 and USB3 external drive as well as a USB2 input device connected at the same time with the 2 external drives transferring data at the same time. With the USB3 Mini's (so 2012, 2014), it is not the case that connecting and running them at the same time will slow the USB3 drive to USB2 speeds (though if you have an external SSD, you might not have enough bandwidth to run multiple devices at the same time at the same speed they have when no other device is running).
     
  4. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #4
    Thanks fellas.

    My issue is that since I use a DAW (digital audio workstation) I have all kinds of things I need to connect. While my ext hdd's are USB3 or FW, I have a mess of 2.0 midi controller devices and software copy protect dongles along with the usual computer keyboard, etc.

    I'm juggling in how to get a stable connection with everything. I have a 3.0 hub, a 2.0 hub a 3.0 bare drive dock as well as usb ports in my monitors.

    Whats been happening is that if I try connecting one way, my audio interface doesn't work, another way, keyboard and mouse doesn't, another, my software goes crazy, lol.

    I actually didn't have these problems from Mavericks and below OS's. Its when I went to Sierra that USB's gone cuckoo. However I believe most of it stems from connecting an ext. Seagate hdd's that are in their own enclosures. I eventually rip the drives out and use them in a dock when I get irritated enough, lol
     
  5. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #5
    I would agree with post #2 that all the ports should be the same. I have not seen anything on the web that indicates otherwise although I haven't much research on the topic.

    However, I have experienced what you have in terms of certain devices not working with certain USB ports on my 2014 Mini. This was with El Capitan when I got the Mini. I just labeled what devices worked in which ports and have stuck with that through Sierra and High Sierra. I have no idea if there would still be an issue if I changed ports or not. All of the external USB ports connect up to the same "USB 3.0 Bus" (according to the System Information app) which would connect to the CPU or a PCH (Platform Hub Controller). This contrasts with my 2009 Mini, where there are two "USB Bus" in the System Profiler so in that case if you have higher throughput (relative to USB2) devices, you want to distribute them between the two buses. My guess is that there may be some power issue that causes certain combinations to work. In my case, 3 of the devices I have connected to the Mini need power, the other doesn't (AC-powered hub).

    Re: Seagate external drives - I have something like ten of them and all of them but one has worked without problems in terms of USB connection, working with different hubs. This one HDD doesn't seem to like being connected to a non-powered hub (I haven't tried it with different models of hubs, I have tried it with two of the same type and the HDD itself is AC-powered). I have had numerous issues with my HDD docks, but the two I have are early (2012-2013) USB3 docks so it may be that an updated one will work more reliably.
     
  6. Wie Gehts, Jun 4, 2018
    Last edited: Jun 4, 2018

    Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #6
    I dunno. Never had error or fail to format issues till I moved to Sierra last summer. I had bought a couple Seagate externals then and Sierra wouldn't format. They would on my older Macbook with Snow Leopard.

    But I had to find out why. So I found others with this issue and what their solution was. I had to use my windows laptop and go in the terminal and type some things regarding something called 'diskpart1' in order to apparently delete that little bit of hidden partition.....think its the EFI partition that I guess is put on there since new disks out of the factory are FAT32 or exFAT formatted.....and once I did that I was able to format to Mac on Sierra OS.

    In my search for solutions, I have come across on some developers forum, such a thing as USB being problematic since El Capitan or Yosemite showed up. I wouldn't be surprised really. I don't put it past Apple to turn users off USB and therefore to Thunderbolt. Then of course, once everyone hypothetically adopts TB as a standard, Apple will then abandon that for something else, lol
     
  7. treekram, Jun 5, 2018
    Last edited: Jun 5, 2018

    treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #7
    So you have 3 issues here.

    First - the USB (your original) issue. So, for me, on my 2014 Mini, I have a EyeTV (USB2) recorder, a USB3 powered hub, a keyboard switch and a video switch (only takes power from hub). On my USB3 hub, I have, at various times, a DAC (USB2), a software license dongle, various external HDD's - almost all USB3, a couple of USB3 HDD docking devices (mentioned earlier), a couple of iPads, some flash drives - USB2 and USB3. So I have a fair amount of variety in what I connect. Obviously not the same as what you have, but probably more than the average user.

    As mentioned earlier, I have observed the port-order issue on my 2014 Mini, which I mentioned earlier, I believe, is the result of some power issue between the USB devices connected to the Mini. By the time the USB data from the external ports come to the CPU in the 2012 or 2014 Mini, it comes over a single bus and there is no discrimination in terms of port order.

    On my 2012 Mini, I don't have the same variety of devices and I still run El Capitan there. I haven't noticed the port-order problem there. Unlike the 2014 Mini, I'll mixup which device goes into which port and I still don't notice an issue.

    I have observed differences in how my HDD docking devices work over the different OS's. On my 2014 Mini I have had El Capitan, Sierra and just recently High Sierra. I didn't notice any uptick in problems going from El Capitan to Sierra. And in general, my USB devices worked without problems on Sierra.

    It's possible you have a hardware issue on the Mini and maybe you should take a trip to an Apple store and have them check your Mini out. But my guess is that you probably you're probably just going to need to troubleshoot. It would help if you have another computer (having Windows would be helpful) to make sure it's not the USB device that's the problem. A different hub (powered would be best) and perhaps not mixing USB2 and USB3 hubs may help. USB3 problems are not unusual as perhaps the specification is not clear or vendors are not implementing it fully - those are my guesses.

    As for formatting in Sierra, people do report that formatting will fail but usually works on the second try. I have that experience more often than not. I don't think having the EFI partition is a problem for disks that are going to be used on a Mac. If you format a completely clean disk in Sierra, I think it will put the EFI partition there. All of my disks (except the APFS disks) have EFI partitions and I haven't had to delete them to get the disk properly partitioned.

    I don't think Apple is creating problems in USB to promote Thunderbolt. They address different needs. Apple will not abandon USB in the foreseeable future. If anything, if Apple goes ARM for it's Macs, they might decide to abandon Thunderbolt and come up with their own proprietary "standard". The problem there, of course, is that they would have to build a user and device base.

    EDIT: I'm still getting familiar with APFS and it turns out the EFI partition doesn't exist on the "synthesized" disk but it's still there on the "real" disk. One of the SSD's (PCIe NVME) can't be formatted by any macOS other than High Sierra, so it was High Sierra that put it there.
     
  8. Wie Gehts thread starter macrumors 6502

    Joined:
    Mar 22, 2007
    #8
    Thanks treekram.

    I had major major major problems at first moving to Sierra and could not understand why as I say, Mavericks was working fine. Then I decided to do a ram check for the heck of it and I actually had a defective 8gb rail of my two. That actually cleared up 98% of what was happening to me.

    What is kinda mind boggling, and the reason for getting tunnel vision in trying to sort out a problem, is the the memory failure coincided with the move to Sierra. This kind of coincidental, 'piling up of problems' disturbingly happens more often than one would think.

    Right now, between the usb ports in one of the 2 displays I use, plus a 3.0 Pluggable hub I just got and an older 2.0 Tripp-lite I think , knock on would, I can have everything connected in one various port or another and it seems to all play nice. lol
     

Share This Page