anarti

macrumors regular
Original poster
Nov 28, 2012
186
0
Scotland
Hi all,

I did an 10.8.3 update for my retina and now the UI lag is terrible.

I keep single app windows on different spaces, and switch to them by clicking dock icon. Transition between spaces is terribly laggy. As far as I remember it was "all right" in 10.8.2, it wasn't clean transition but I learned how to live with it. Now it's just awful.

I have 2 15" retinas at home, same on both computers.

I switched to non HDPI resilution, which is kind of blurry compared to HDPI but transitions are as they should be, no lag, there is no scalling so everything works perfectly.

I really like that computer, but this lag is driving me crazy.

I did smc reset, nvram reset etc. No improvement.

Was wondering if any of you guys have same sympthoms.
 

anarti

macrumors regular
Original poster
Nov 28, 2012
186
0
Scotland
I can believe that there might be somthing wrong with 1 laptop, but with 2 laptops, bought within 2 months from each other. I can't believe that there is something wrong with this perticular one.

Was wondering if anyone else is experiencing simmilar problems
 

Trubbles

macrumors regular
Oct 20, 2012
104
22
I've found 10.8.3 to be smoother than 10.8.2.

Perhaps some utility you have installed is interfering?

I had a program (and educational tool called Greenfoot) that caused UI lag any time I had it open unless I turned to a non-hiDPI resolution. That was back in 10.8.2.

If I were you, try disabling any and all utilities you have running... worth a shot. Otherwise I agree with the poster above - take it to the Genius Bar.
 

anarti

macrumors regular
Original poster
Nov 28, 2012
186
0
Scotland
Trubbles, thanks for help but I'm afraid this lag starts from entering the user password. It's not related to running specific program.

So you don't have any lag when switching workspaces using method I mentioned?

It is so frustrating.
 

Trubbles

macrumors regular
Oct 20, 2012
104
22
Trubbles, thanks for help but I'm afraid this lag starts from entering the user password. It's not related to running specific program.

So you don't have any lag when switching workspaces using method I mentioned?

It is so frustrating.

I have MS Office suite running on "Desktop 1" and some programming tools running on "Desktop 2" and Parallels and Chrome running as a full screen applications and I have no noticable UI lag. In fact, I might be imagining it, but I think it's LESS laggy than 10.8.2.
 

robvas

macrumors 68040
Mar 29, 2009
3,240
627
USA
With the higher resolutions, it looks like the screen is running at a lower FPS even if it's not. Weird, but I've noticed this since the old days and going from 320x200 to 640x480, even if you have it locked at 30fps the higher resolution looks 'slower'
 

anarti

macrumors regular
Original poster
Nov 28, 2012
186
0
Scotland
Trubbles, thanks.

When switching workspaces by swiping trackpad it's super smooth, only when clicking on specific app icon in dock, then there is a lag, like a small jump, not smooth. In non HIDPI it's super smooth as well.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.