Late 2013 13" MBA USB issues

Discussion in 'MacBook Air' started by ltjlily17, Feb 3, 2014.

  1. ltjlily17 macrumors newbie

    Joined:
    Apr 23, 2010
    #1
    I have a late 2013 13" MBA with 8gb ram and a 256 SSD. I am using a Logitech USB wireless mouse and a Plantronics Gamecom 780 Headset for playing/streaming games.

    At first, the headset and mouse worked fine, I used them both when playing for about three weeks with no issues. Two days ago, when I plugged in my headset, I could only hear audio on one side. I plugged it into our desktop (Win7) and it worked fine. I plugged it into the other USB port and it worked fine. I moved the mouse USB over to the port the headset didn't work properly in and it didn't recognize it. I restarted my machine and was able to get them to work.

    Yesterday, I was unable to get the mouse to work at all and the headset only received audio on one side in that USB port. I've restarted my machine and did the diagnostics, with no issues. Today is the same story.

    I did not receive any updates in between it working and not working. It is the USB port on the left, next to the magsafe.

    Anyone have any suggestions for troubleshooting this?

    Thanks
     
  2. nickandre21 macrumors 6502a

    Joined:
    Jun 21, 2012
    #2
    I have had an issue with my retinas usb port the strange thing was that port would only work with usb 3.0 other devices would not recognize. So it should be a hardware issue but first to make things sure go into recovery mode and see if your mouse works on that port if it does then reinstall if not you are looking at a logic board or i/o board replacement, hope you are on warranty/apple care
     

Share This Page