Late 2013 13" rMBP Not Sleeping

Discussion in 'MacBook Pro' started by gametime10, Dec 20, 2013.

  1. gametime10 macrumors regular

    Joined:
    Mar 30, 2006
    #1
    Anyone else having this problem? Any known solutions?

    I was hoping 10.9.1 would fix this, but no. I'm trying to remember to shut it down each time, but I sometimes forget. Woke up this morning with a 0% battery again.
     
  2. jondunford macrumors 6502

    jondunford

    Joined:
    Oct 22, 2013
    Location:
    Going for a poo Moderator
    #2
    yes

    no
     
  3. TheEnthusiast macrumors regular

    Joined:
    Aug 22, 2013
    #3
    Did you make any modification to the sleep image?
     
  4. jondunford macrumors 6502

    jondunford

    Joined:
    Oct 22, 2013
    Location:
    Going for a poo Moderator
    #4
    nope but it only happens (for me) about 50% of the time :confused:

    i get tired and go to sleep thinking my mac will do the same so not bothering to manually sleep it, and wake up and its dead
     
  5. tugarul3z macrumors newbie

    Joined:
    Jun 12, 2013
    #5
    Try this:

    in terminal, type >pmset -g assertions
    This lists if a PreventSleepCondition exists, and lists the culprits.
    My result:
    pid 17: [0x0000012c00000011] PreventSystemSleep named: “org.cups.cupsd”
    pid 278: [0x0000012c00000116] PreventUserIdleSystemSleep named: “com.apple.audio.’AppleHDAEngineOutput:8,0,1,2:0′.noidlesleep”
    typing:
    sudo kill 17 (password required)
    and
    sudo kill 278
    got my macbook pro to sleep with power connected. On reboot these might reload, however I now know the culprits.
     
  6. tigerintank macrumors regular

    Joined:
    Jun 16, 2013
    #6
    i get

    pid 207(coreaudiod): [0x0000000100001167] 00:08:03 NoIdleSleepAssertion named: "com.apple.audio.'AppleHDAEngineOutput:1B,0,1,1:0'.noidlesleep"
    pid 17(powerd): [0x000000090000012c] 88:43:57 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"
    Kernel Assertions: 0x24=USB,THNDR
    id=500 level=255 0x20=THNDR mod=21/12/2013 15:07 description=NHI0 owner=AppleThunderboltHAL
    id=501 level=255 0x4=USB mod=17/12/2013 22:29 description=XHC1 owner=AppleUSBXHCI
     
  7. gametime10 thread starter macrumors regular

    Joined:
    Mar 30, 2006
    #7
    I get:

    Assertion status system-wide:
    BackgroundTask 0
    PreventDiskIdle 0
    ApplePushServiceTask 0
    UserIsActive 1
    PreventUserIdleDisplaySleep 0
    InteractivePushServiceTask 0
    PreventSystemSleep 0
    ExternalMedia 0
    PreventUserIdleSystemSleep 0
    NetworkClientActive 0
    Listed by owning process:
    pid 77(hidd): [0x0000000a00000155] 00:03:36 UserIsActive named: "com.apple.iohideventsystem.queue.tickle"
    Timeout will fire in 3580 secs Action=TimeoutActionRelease
    Kernel Assertions: 0x100=MAGICWAKE
    id=502 level=255 0x100=MAGICWAKE mod=12/31/69, 4:00 PM description=en0 owner=en0
     
  8. ggn1971 macrumors newbie

    Joined:
    Sep 27, 2012
    #8
    Have you tried to deactivate PowerNap when on battery?
     

Share This Page