Late 2013 Mac Pro D500's issues with gaming in windows 8.1 using boot camp

Discussion in 'Mac Pro' started by Ruvengeance, May 21, 2015.

  1. Ruvengeance macrumors newbie

    Joined:
    May 21, 2015
    #1
    Okay so I bought a new Mac Pro yesterday hoping to play Witcher 3. Loaded bootcamp, installed windows 8.1, installed all the windows updates and downloaded steam and witcher.

    As soon as I started playing the game I was getting less then 30 fps the whole time. I kept turning graphics down all the way until I was at the lowest settings for everything and could still not keep up with 20fps on average.

    I have a hard time believing that this computer cannot run witcher 3 on the lowest setting at 30 fps.

    Made sure all the drivers were up to date. Went to device manager and clicked on the D500's and hit check for update they were up to date. Ive tried to disable crossfire X as some people said it was giving them issues, but as soon as I did that my screen just started to flicker and getting horizontal lines randomly. So i turned it back on to avoid the issue.

    Anyone have any help or suggestions??

    Things I cant do:

    Reinstall windows on and reformat that partition (Dont have a copy of Windows anymore to use)

    Redownload witcher 3 ( I have less then 50 gb of data left for the month on xfinity.)


    Looking for any help, Thanks!!
     
  2. Avenger macrumors 6502

    Joined:
    Sep 20, 2007
    #2
    The bootcamp drivers are as old as dirt. You can try the method in
    http://forums.macrumors.com/showthread.php?t=1869023
    To get the latest via a hack. But the witcher 3 15.5 drivers haven't been released yet so you will not get optimal crossfire and there is some flickering.
     
  3. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    1) There is some drama going on about this (Witcher 3 on AMD).
    http://arstechnica.co.uk/gaming/201...s-completely-sabotaged-witcher-3-performance/

    Basically, Witcher 3 uses Nvidia hair rendering and not AMD hair rendering.

    2) Your D500 is actually slower than the base D300 except for double precision compute tasks.
    http://forums.macrumors.com/showthread.php?t=1764381
    http://forums.macrumors.com/showthread.php?p=18581383#67
     
  4. Ruvengeance thread starter macrumors newbie

    Joined:
    May 21, 2015
    #4
    Okay I tried going through that but when I run the .exe files to unpack the catalyst and beta version it gave me and error code stating that i didnt have the supported hardware.
    When I went to the AMD website to download the drivers after completely erasing all existant ones, there wasnt any options for the D500 so I downloaded the ones for the HD7*** ones since that is the equivalent.
     
  5. Avenger macrumors 6502

    Joined:
    Sep 20, 2007
    #5
    Those unsupported messages are alright. Follow the instructions to the last step. After you move everything into the right place, the drivers will install.
     
  6. Ruvengeance thread starter macrumors newbie

    Joined:
    May 21, 2015
    #6
    Okay I moved everything to the right place but when I ran the setup.exe file thats outside of the Bin64 folder, It gave me an error message saying " CATALYST Install manager has stopped working" right after I hit the custom install in the Analyze section. I ran The driver removal tool one more time but it gave same error code. Threw both the Beta and omega drivers to recycle bin. Reran the .exe to unpack them to my desktop. Put the Bin64 files from the Omega into the Beta and put the 2 files from Bootcamp>Drivers<ATI<ATIGraphics<Bin64 into the Bin64 of the Beta and ran the setup.exe again it gave same error message.

    It stopped right at the "Detecting Graphical Hardware" step
     
  7. Mattstrete macrumors member

    Joined:
    Nov 14, 2011
    #7
    I think that I may be of assistance.

    I reverted to the “Omega” drivers given that the 15.4 beta drivers were TERRIBLE for anything other than GTA V.

    I am currently playing the Witcher 3 at 1440p resolution with all settings on high (other than foliage visibility range, which is a bit lower) on my nMP with D500s. The frame rate is a bit lower than 60, probably around 45-50, which is totally acceptable. Crossfire is OFF. No profiles are currently working. You could try force “AFR friendly” crossfire and it will almost double your frame rate but you will experience terrible flashing and graphics corruption.

    You will need to overclock to 1000 mhz (core) to get this kind of performance.

    So:
    - Install the Omega drivers. This is a far simpler procedure than the method I posted in relation to the 15.4 Beta drivers.
    - To do this, first run “display driver uninstaller” to remove all traces of your current drivers. This will require that you reboot Windows in safe mode, but the process is fairly well automated.
    - You should then reboot windows as normal and “unpack” the Omega drivers and, in their Bin64 directory, replace the “installmanager” .exe and .dll files with the same files from the latest AMD bootcamp drivers (December 2014).
    - After you do this, run the setup.exe file in the Omega drivers directory. This should allow the installation to proceed.
    - If, after installation, you are missing the catalyst control centre, you will need to rerun display driver uninstaller and, whilst booted into safe mode, run regedit.exe from a command prompt and search for all references to “ATI” in the local user’s “software” section of the registry. Sorry I cannot be more specific but my mac pro is currently powered off (there’s a power failure where I live, at the moment).
    - Once you have installed the Omega drivers, create a custom profile in catalyst control centre for the Witcher 3. The only setting that you need to change is the crossfire setting: you must disable crossfire. You should also make sure that the box labelled “enable crossfire for games with no associated profile” in the main crossfire settings tabs is NOT checked.
    - Then, overclock your GPU with MSI afterburner, to the extent required.

    I have been very impressed with how well the Witcher 3 is now running considering the volume of complaints on various forums. If you want to run at 1080p you will probably be able to run with quite a few settings on ultra. However, make sure that you disable “hairworks”, completely, in the video options as this tanks performance on AMD cards.

    I hope this helps.

    And finally – I don’t agree that the D500s have “worse” performance than the D300. The D500 has been shown to be based on a Tahiti core (or a variant thereof), is basically a downclocked HD7970 (or better) and has far greater memory bandwidth than the D300, which is based on an earlier chipset.
     
  8. ojanb macrumors newbie

    Joined:
    Apr 24, 2015
    #8
    After you have done this i would suggest you to check this thread.
    Im getting seriosly smooth gaming in bf4, gta 5, arma 3, day z and so on
    after doing those few tweaks.

    D500 being better or worse than D300 you can still get 60 fps on ultra settings in new games anyway.

    http://forums.macrumors.com/showthread.php?t=1882500
     
  9. Mattstrete macrumors member

    Joined:
    Nov 14, 2011
    #9
    [I am currently playing the Witcher 3 at 1440p resolution with all settings on high (other than foliage visibility range, which is a bit lower) on my nMP with D500s. The frame rate is a bit lower than 60, probably around 45-50, which is totally acceptable.]

    I did more testing yesterday. My framerate estimate, above, was a bit too high. I'm seeing frame rates at 1440p in the 30-33FPS region with most settings on high. Gameplay is smoother with the in-game 30FPS lock enabled.

    Framerates at 1080p are around 40.
     

Share This Page