late 2013 rMBP can't connect to 802.11ac network, Help~

Discussion in 'MacBook Pro' started by Turbocharged, Jan 22, 2014.

  1. Turbocharged macrumors newbie

    Joined:
    Nov 18, 2013
    #1
    just bought an ASUS ac68u router, configured both 2.4GHz and 5GHz separately with different SSIDs.

    my rMBP can find and connect to 24GHz network just fine, but only in 802.11n

    it cannot even find the SSID of 5GHz network. tried different channels and modes, tried to reboot both router and laptop, still can't find the 5GHz network, any help?
     
  2. Ai-apple macrumors regular

    Joined:
    Nov 1, 2013
    #2
    I got AC68U and every settings were set as from the factory default. I have latest F/W .538 on AC68U. My rMBP is connecting 802.11AC on 5GHz. Are you using WPA2?
     
  3. Turbocharged thread starter macrumors newbie

    Joined:
    Nov 18, 2013
    #3
    mine is on .538 FW as well, rMBP just refused to find the 5G network, while my Nexus 7 2013 can connect to 5G network at 20MHz, having problem at 40 and 80 too.
     
  4. Ai-apple macrumors regular

    Joined:
    Nov 1, 2013
    #4
    You can check on your rMBP if the [system information>network>wifi] is showing your 5Ghz network.
     
  5. rex450se macrumors regular

    Joined:
    Apr 9, 2011
    Location:
    Independence, MO
    #5
    I have that same router and don't have any issues. I have mine set up with 2 different SSID's so that everything else in the house is on one and my rMBP which is the only AC device in the house is on the 5 Ghz channel. I am on the other end of the house, about 3000 sq ft, and have great signal strength. I can't think of anything I did special setting it up. I wish I could be of more help.

    Victor
     
  6. Jasonx82 macrumors member

    Joined:
    Nov 18, 2008
  7. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #7
    I think something is wrong with your router.

    I own like five of them and two of them didn't work out of the box. One keeps freezing and I have to manually power cycle it and the other often loses connection.

    I have since replaced them all with Apple AirPort Extreme APs; I do lose some performance, but at least they work reliably.
     
  8. Turbocharged thread starter macrumors newbie

    Joined:
    Nov 18, 2013
    #8
    Thanks guys.

    I'll try again later, I'll exchange it later if it still doesn't work. or maybe I should bring it to an Apple store, just to make sure it's not caused by rMBP first before turn to ASUS.
     
  9. Turbocharged thread starter macrumors newbie

    Joined:
    Nov 18, 2013
    #9
    solution found.

    Called ASUS, the problem was that I did not do a "reset to default" after update the FW, the tech support says sometime this happens after an update.

    just do a reset and configure the router again, now without any additional change, everything connects.
     

Share This Page