Late 2013 rMBP Locked SSD.

Discussion in 'MacBook Pro' started by r3dm4n, May 7, 2015.

  1. r3dm4n macrumors newbie

    Joined:
    May 7, 2015
    #1
    Hi guys,
    I have a late 2013 rMBP i7, 16gb ram, nVidia 2gb and 500 gb PCIe based SSD.
    I recently purchased an external HDD and wanted to move Bootcamp there, not knowing it's not possible ..deleted Bootcamp partition from Disk Utility instead of Bootcamp.

    Now my Macbook Pro doesn't see my internal SSD.. I've been stuck for about a week now and don't know what to do.

    I can't boot into Recovery HD neither.
    When I go to Internet Recovery it shows my internal drive for about 2 minutes then it disappears like magic. I can't delete it from terminal or disk utility no matter what I do.

    Now the funny thing. OS X was booting just fine until today, even though I couldn't erase it or see it in Internet Recovery, I just opened the macbook and it worked ok, do whatever I want...Booted directly into Yosemite. It's just I want to erase completely and do a fresh reinstall .. So from terminal in OSX I converted my drive to core storage, to see if anything changes in Internet Recovery and I can see my drive .. convert it back to HFS+, delete it or something ... Now I am completely stuck !

    I am now running OSX from an external drive ...where of course I can't see my internal SSD.

    I am completely locked.

    Please tell me what I can do.

    Last resort.
    There is no apple store here, or in the country. I bought it from Amazon uk and had it shipped.
    As a last resort, should I send it to Amazon or to Apple ?
    I bought the macbook in March 2014 .. last year. Is it still covered by the warranty ? European Warranty is 2 years, but I read on Apple uk that in the UK is 6 years.
    Also I read something that it's only for 1 year .... I don't know what to believe anymore.
     
  2. laurihoefs macrumors 6502a

    laurihoefs

    Joined:
    Mar 1, 2013
    #2
    Have you reset SMC and PRAM?

    Running Apple Hardware Test might be a good idea to rule out hardware defects.

    Does the drive or volumes just disappear completely from the disk utility list, or does the Macintosh HD volume turn gray? Is the round blue Unlock button available, if you select the volume in Disk Utility? Try selecting the volume, press unlock, and see if you get to enter your password and mount the volume.
     
  3. r3dm4n thread starter macrumors newbie

    Joined:
    May 7, 2015
    #3
    I've reseted SMC and PRAM countless times, nothing changed.
    I just ran Apple Hardware Test and it said "No issues found. Reference code: ADP000"

    Until today when I really messed it up and converted the drive to Core Storage, I noticed under OSX that I the "EraseFreeSpace" option was greyed out as well.
    Funny thing is I was able to repartition ...I even did a second partition, downloaded Yosemite from the AppStore and the instalation went trough, but when it finished OS X just wouldn't load.
    When I did this and just my main Macintosh HD partition it wouldn't load at all.

    The drive disappears completely in disk utility after about 1 minute.
    I've also enabled Debug Menu .. checked show every drive and every partition .. still doesn't show up. Only thing that shows up is "OS X Base System"

    I can't even describe how nice is to run OSX on an external 5400RPM USB2.0 drive :)

    Do you have any other ideas on what to do?
     
  4. Synergie macrumors 6502a

    Joined:
    Jan 15, 2011
    Location:
    Halifax, Canada
    #4
    Just as a side note... could the hard drive cable have maybe crapped out?? Mine did and it was off and on for about a week, until the other day, when all of a sudden it could not find the drive anymore in Disk Utility.

    If theres nothing wrong with the cable, and you boot from an external hard drive, no matter how much you've messed up the contents on that drive, you should still see it to be able to format it.
     
  5. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #5
    No hard drive cable in an rMBP. They use a blade type SSD.
     
  6. laurihoefs, May 7, 2015
    Last edited: May 7, 2015

    laurihoefs macrumors 6502a

    laurihoefs

    Joined:
    Mar 1, 2013
    #6
    You could try GParted live on a bootable USB flash drive.


    Here's one way to make the flash drive:

    1. Download the ISO-image here: http://gparted.org/download.php

    2. Connect the USB drive, open Terminal.app and type:
    Code:
    diskutil list
    3. See which device is your USB drive, and unmount the volume(s) on it (replace X and Y with appropriate disk and slice numbers):
    Code:
    diskutil umount /dev/diskXsY
    4. Write the image you downloaded to the USB drive (assuming the image is in your Downloads folder):
    Code:
    sudo dd if=~/Downloads/gparted-live-0.22.0-1-i586.iso of=/dev/diskX bs=4m; sync
    Boot your computer with the USB drive, and see if you can modify the partitions.


    If you can't access the partitions, you can also try a secure erase. To do that on GParted live, open a terminal window, and write (replace X with disk letter):
    Code:
    hdparm --security-erase NULL /dev/sdX
    Note: this will completely erase everything on the SSD!
     
  7. r3dm4n thread starter macrumors newbie

    Joined:
    May 7, 2015
    #7
    I tried that program, doesn't see my internal drive.

    Just came back from an Apple reseller, not official or authorized service. They connected the Macbook to an iMac via Thunderbolt cable and it saw my SSD, they reformated, erased it all etc, worked like a charm.

    When you go to Recovery HD or Internet Recovery STILL DOESN'T SEE my internal SSD, it vanishes after 30 sec-1 min.

    I am now typing this from my internal SSD, because it boots directly into OSX and everything works perfect.

    So, bottom point is:
    Target mode sees internal SSD
    OSX works
    SSD has just been completely erased from target mode

    SSD is not detected in Recovery HD or Internet Recovery !

    What else is there to be done?

    The reseller I mentioned said I could send it to Bucharest where there is a Premium Apple Reseller and they are authorized and accept my warranty.

    Suggestions please ...
     
  8. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #8
    I did a quick search, and Core Storage is actually intended for the Fusion drive that Apple uses in it's new Retina iMac - NOT on a SSD. Here's an article on how to non-distructively convert it back.

    In reading through the comments, this may...or may not...work for you in your case. If it does not, you're looking at needing to do a clean install, which means creating a USB install drive of Yosemite. If you do this, when you boot to the install screen, run disk utility first on the internal SSD and erase/partition the drive (name it Macintosh HD) so that the OS installs correctly.
     
  9. laurihoefs, May 8, 2015
    Last edited: May 8, 2015

    laurihoefs macrumors 6502a

    laurihoefs

    Joined:
    Mar 1, 2013
    #9
    Yosemite uses Core Storage by default.

    See for example OS X 10.10 Yosemite: The Ars Technica Review
    Even existing OS X partitions are converted to Core Storage during Yosemite upgrades.

    At this point I would most likely send it to Bucharest.

    Both the original one year warranty and AppleCare are international, so if either is still valid, any Apple Authorized Service Provider anywhere will repair your laptop.

    Still, it's a really strange issue. Hopefully you'll find a solution!
     
  10. r3dm4n thread starter macrumors newbie

    Joined:
    May 7, 2015
    #10
    Thanks. I'll send it on Monday and see what they say.
     
  11. r3dm4n thread starter macrumors newbie

    Joined:
    May 7, 2015
  12. laurihoefs macrumors 6502a

    laurihoefs

    Joined:
    Mar 1, 2013
    #12
    Good to hear the issue was resolved :)
     

Share This Page