Late 2015 4K intermittent display issue

Discussion in 'iMac' started by drewsof07, Mar 14, 2017.

  1. drewsof07, Mar 14, 2017
    Last edited: Mar 14, 2017

    drewsof07 macrumors 68000

    drewsof07

    Joined:
    Oct 30, 2006
    Location:
    Ohio
    #1
    Have a user with this weird issue on their 4K iMac with integrated graphics. She says it occurs randomly and persists for about 15 minutes across the screen, application agnostic. She finally sent me a photo of it in action (attached). Basically, hues of cyan, magenta, and yellow. I checked the serial and this machine just fell out of warranty. This is a business machine used 40hrs/wk. I have no hot swaps, so "just take it to the genius bar" is going to be a last resort. It doesn't seem like a hardware issue to me, but any advice would be appreciated.

    Thx

    Potato cam pic:
    Screen Shot 2017-03-14 at 9.56.06 AM.jpg
     
  2. curmudgeonette macrumors 6502

    Joined:
    Jan 28, 2016
    Location:
    California
    #2
    Suspect this is the Sierra 24 bit vs 30 bit graphics bug that affected so many 2016 MBPs. Is this computer running the latest macOS?
     
  3. drewsof07 thread starter macrumors 68000

    drewsof07

    Joined:
    Oct 30, 2006
    Location:
    Ohio
    #3
    Yes, it appears to be running 10.12.3. The 4K panel is marketed as P3, would this be the culprit? A quick google didn't reveal any results on this particular issue. Trying MR now...
     
  4. curmudgeonette macrumors 6502

    Joined:
    Jan 28, 2016
    Location:
    California
    #4
    Nope. It is just a software bug.

    Someone posted with this problem with one of the early Sierra betas. The thread didn't get many replies 'cause I guess the problem wasn't common. Discussion finally started when the 2016 MBPs showed this problem. It is unclear if Apple has fixed this or not.

    One solution is to go back to El Capitan.
     

Share This Page