Late MBP 2008 and 240GB Intel 520 Cherryville issues?

Discussion in 'MacBook Pro' started by mpress, Mar 21, 2012.

  1. mpress macrumors newbie

    Joined:
    Mar 21, 2012
    #1
    Has anyone else encountered any issues a late 2008 MBP with the 240 GB Intel 520 Cherryville? It has the SF-2281 controller with Intel's custom brewed firmware that solved the issues plaguing the SF-2281.

    When I first put in the drive and booted it up to Snow Leopard install disc, it does not even see the SSD. If I go under under Serial-ATA in system report, I see the message "There was an error while scanning for Serial-ATA devices." Restarting and trying again yields the same thing.

    So then I go take the drive and pop it into a PC laptop and try installing linux to make sure it is not DOA. It did fine. Installed fast and then booted up fast. Operated as expected.

    Went ahead and located my Lion disc and reinstalled the SSD into the MBP. Booted up and the SSD showed up. Partitioned it with extended journaled and proceded to install. During installation, I noticed something I did not know with my original Samsung 128GB SSD. The installer stated that I had nearly two hours for the install. I thought this was weird, being an SSD and I do not remember it taking this long with my 128GB SSD. Some time after with 1:15 remaining, I feel asleep watching paint dry.

    A few hours later I woke up to seeing the display fully lit with the DVD drive spinning at full and me staring at the grey screen with a circle and horizontal cross going through it. I think it was blinking. I went ahead and held the power button to turn it off and to deal with it later.

    I know this SSD with have bottleneck issues with this MBP since it is not SATA 3, but the price was too good to pass up along with Intel's reputation and the 5 year warranty.

    Anyone else with issues? :confused:
     
  2. mdgm macrumors 6502a

    Joined:
    Nov 2, 2010
    #2
    I think from memory the late 2008 MBP is a model that has issues with SATA III SSDs. Best to use a SATA II SSD with this machine.
     
  3. mpress, Mar 21, 2012
    Last edited: Mar 21, 2012

    mpress thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #3
    Thanks for the reply. I'll look into this. :)

    I saw this thead, which maybe some having success with the it on a MacBook5,1:

    http://forums.macrumors.com/showthread.php?t=1337133

    Mine is an MacBookPro5,1 though and they only mentioned bottleneck issues, which I already knew about, but didn't expect the Lion install to take longer than the Samsung SSD that originally came with it, not to mention that the drive cost nearly twice as much as this Intel one back in 2008 :(

    EDIT: For others referencing, I see something here that maybe of use...still looking:
    http://forum.corsair.com/forums/showthread.php?t=98689
     
  4. mdgm macrumors 6502a

    Joined:
    Nov 2, 2010
    #4
    The MBP and MB are two different machines.

    If you use a SATA II SSD it should run at SATA II speeds.

    A SATA III SSD would be negotiated at SATA I and be unreliable I think.

    I'd return the SSD if you can and get the older SATA II model.
     
  5. mpress thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #5
    It's seriously unreliable. I had a chance to try to boot it back up. Every few minutes when interacting with applications, the applications seem unresponsive (not frozen according to force quit app window), and I can move the mouse but all I get is the spinning beach ball for a few minutes. Afterwards it unfreezes and acts normal. It happens every few minutes and is really unusable.

    There were a few times when it failed to boot. I get the grey screen with either a folder with a question mark, circle with a diagonal line through it and Apple logo.

    Negotiated link speed is 1.5 gigabits and link speed shows 3.0 gigabits when it I am able to go into Lion. This is the same that is displayed when I put in my Apple 128GB SSD (originally what came with MBP).

    I just wanted to upgrade and have more space. Intel seems reputable enough with the 5 year warranty, but the only questionable part was the SF-2281 controller, but reading about how they have their own custom firmware was enough for me to give it a chance.

    The Intel 520 SSD acts normally when I put it into my PC laptop that has only support for SATA 1.5 and no SATA 2 support though.

    Unfortunately I cannot return this drive. Merchant will only exchange, but I doubt anything is wrong with this except it either this MacBookPro5,1 may not like the Sandforce.

    I even try disabling the energy saver setting for putting hard drive to sleep when possible. The MBP has all firmware and even when I installed all of Lion's updates there was no change in behavior--still spinning beach ball of death. I may try reloading Lion completely again and seeing how it goes.

    So far with my experience, I do not recommend this Intel 520 Cherryville for anyone running MBP5,1. I just contacted Intel support to see what they have to say.
     
  6. mdgm macrumors 6502a

    Joined:
    Nov 2, 2010
    #6
    Do see what they have to say. I guess I'd suggest using the SSD in your PC laptop then.

    The MBP5,1 is a bad model to have for using SSDs. OWC recommends 3G SSDs for this model, I think.

    I'm guessing the Intel SATA II (3G) SSDs which aren't Sandforce would also work fine in this model (though I don't know). Considering this model can't do SATA III anyway there's not that much of a performance loss (if anything) using SATA II SSDs.

    I have a SATA III SSD. My personal advice though would be if in doubt to use SATA II SSDs. Even in the 2011 MBPs (these have SATA III) there have been issues with SATA III SSDs. Should hopefully be better with the 2012 model.
     
  7. mpress thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #7
    So this is the latest update...I took the Intel 520 and stuck it into my MBP5,5 at work with the Lion that I still had tried loading it with my MBP5,1. Absolutely NO freezing issues whatsoever. It was perfectly fine like when I was running Linux on that PC laptop with SATA 1.5. Speed was fast and smooth. That MBP5,5 also showed that the link speed was 3 GiB/s and the negotiated link speed was 1.5 GiB/s.

    For grins I reloaded Lion from scratch on that MBP5,5 with the 520. I loaded other applications that I typically load. I brought it home and stuck it into my MBP5,1 and it would not even boot up. It had the folder with question mark, then cycled through that, the circle with diagonal cross, and also the apple logo.

    I also heard back from Intel. This is disappointing to hear since they do not explicitly state any compatibility with any OS. They only may have tools for Windows but that does not imply anything. Their PDFs for checking to see if a computer supports SSD shows them using the Windows device manager, but that is just a way to tell and does not imply any OS support either.

    What is most disappointing is the fact that hardware such as this is supposed to be independent of any OS with respect to nothing weird like say an XBox having secret code to look for specific hardware. This is a plain and simple hard drive swap. I have never seen any MBP reject any non-SSD SATA before. SATA is also standardized with support for backward compatibility so unless Apple was fudging the hardware vendors to their favor then as long as it is SATA, then there should be no issues.

    Here are some excerpts from the reply:
    This being one of the first generations of unibody is filled with flaws like this. This may also be one of my first and last Intel SSDs!

    I remember back then finding out that only 4 GB of RAM was officially supported on this Late 2008. Then when I had issues with the Super Drive, and I decided to replace it myself, I ordered a Sony Optiarc that was made for MBP and installed it. Upon installing it, I discovered a dirty Apple secret. One of the mount holes on the unibody was asymmetric to standard symmetric designs. I had to hack the Optiarc casing but even then the screws head now just barely holds down the tip of the drive's casing. It is such a shame.

    Now for some testing whether to rule out if it is SandForce use with the MBP5,1 being a SATA III SSD or issues with the SATA 1.5 implementation on this MBP5,1 in general. With SATA III and SATA II being industry standardized, backward compatibility specifications should be followed so that interoperability with SATA 1.5 is possible and without issues. I will obtain an SATA III HDD to test.

    Will report back. :p Does anyhow know if Apple has a HDD/SSD hardware compatibility list somewhere? I have searched and found nothing. :(
     
  8. mpress thread starter macrumors newbie

    Joined:
    Mar 21, 2012
    #8
    So I finally got a chance to install an HDD:

    Seagate Momentus 7200.4 ST160LT016
    160GB 7200 RPM 16MB Cache 2.5" SATA 3.0Gb/s

    Link speed and negotiated link speed both show 3 gigabits.

    Lion works fine and without issues. It also installed without issues. It must be the SandForce at work here or a combination of SandForce SF-2281 and SATA III. I do have a SSD with SF-1200 but is SATA II at my disposal I maybe able to try out. I am definitely not buying another SSD with SF-2281 though...whomever wants to send it to me so I can test, I will gladly accept :eek:

    I did just come across this:
    http://forums.macrumors.com/showthread.php?p=14651644

    Another MBP5,1 user with the Cherryville having no issues except seeing the negotiated link speed at 1.5 gigabits. Go figure, Intel :rolleyes:
     
  9. thefizzle657, Apr 1, 2012
    Last edited: Apr 1, 2012

    thefizzle657 macrumors regular

    Joined:
    Oct 21, 2011
    #9
    I think the issue is not so much with the Intel SSD as it is with your computer. As noted above the 5,1 MBPs don't play well with SATA III 6Gbps drives for some reason and so it is recommended only to use a SATA II 3Gbps drive. If it is anyone's fault it is Apple's fault (maybe not their "fault" per se, but rather that there is some sort of hardware issue with those MBPs). Since the problem occurs with all or most SATA III SSDs but doesn't occur with SATA II I think that it is reasonable to conclude that there is some issue with either the SATA cable, the controller, or something else in those MBPs. It doesn't sound like it is an Intel or Sandforce issue.

     

Share This Page