Late08 MBP Magsafe Adapter loose!

Discussion in 'MacBook Pro' started by SchneiderMan, Nov 10, 2008.

  1. SchneiderMan macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #1
    anyone else have this problem with the new late mbp 85w magsafe adapter? should i get a new one?
    its really loose, i can move it alot.
     

    Attached Files:

  2. south8212 macrumors 6502

    Joined:
    Oct 18, 2008
    #2
    yeah mine is like that too. Its made to come off so it should be a little loose, just slide it off and put it back on and see if that helps at all.
     
  3. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #3
    no it doesnt help, i also have the little magsafe adapter for the iphone and ipod classic and it doesnt move at all. :confused:
     
  4. imapfsr macrumors regular

    imapfsr

    Joined:
    Feb 14, 2008
    Location:
    Victoria, B.C.
    #4
    same here, I did click it back in and it seemed to help so.....
     
  5. teleromeo macrumors 65816

    teleromeo

    Joined:
    Dec 2, 2006
    Location:
    kidnapped by aliens
    #5
    that looks not normal, go get a new one if you don't like it.
     
  6. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #6
    is there any benefit using it like that or using it w/ the extra cord?
     
  7. Mercellus macrumors regular

    Joined:
    Nov 4, 2008
    #7
    My MagSafe adapter has a very slight angle to it when using the two-pronged adapter, however it's not as large as the gap in the picture that you have posted. I would contact AppleCare or an Apple Store at your earliest convenience and ask them if there is any way they can replace the adapter due to this issue.
     
  8. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
  9. steve31 macrumors 6502a

    steve31

    Joined:
    Jul 20, 2007
    Location:
    Edmonton Canada
    #9
    Mine are all like that. I have been using mine like that for over a year with no problems. You could use it with the cord if your worried.:D
     
  10. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #10
    ive just checked the cord plug and it has the same issue. i think its the magsafe itself :(
     
  11. Mercellus macrumors regular

    Joined:
    Nov 4, 2008
    #11
    It sounds like for whatever reason, the actual adapter is somewhat warped and that the accessory bits aren't connecting the way that they should be. I would ask for a replacement adapter just to be on the safe side, a little gap isn't an issue and it's definitely not a hazard, but something like this is a bit worrying.
     
  12. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
  13. gobbypower macrumors newbie

    gobbypower

    Joined:
    Jul 22, 2008
    Location:
    ATL
    #13
    nope, ive had my mbp for a couple of weeks, and I dont hav that problem.
     
  14. imapfsr macrumors regular

    imapfsr

    Joined:
    Feb 14, 2008
    Location:
    Victoria, B.C.
    #14
    Mine is the same as yours. I clicked it back in but just checked it today and it has the space or gap again, obviously defective.:(
     

Share This Page