Latency when recording in Audacity

Discussion in 'Digital Audio' started by dauber, May 1, 2015.

  1. dauber macrumors regular

    dauber

    Joined:
    Jan 10, 2012
    Location:
    Chicago
    #1
    Okay, to preempt the obvious "Google is your friend" response (a phrase I have a problem with on SO many levels, btw), I've done the obligatory web searching...but here's what's going on...

    My friend and I just started a podcast (in case you're curious, Pie Factory Podcast, available in iTunes...long story VERY short, two retro arcade games per episode)...and there's a major quirk that's annoying me...

    Now...we talk to each other over Google Hangouts. I plug a pair of headphones into my speakers. I can hear him fine. We each record ourselves and we later sync our recordings together. I'm using the latest Audacity on OSX Yosemite with the latest updates installed. Mid-2011 iMac (details in my sig or description or whatever). I'm using a Zoom H2 Handy recorder as a microphone.

    Again, I can hear my friend fine in real time, and he hears me fine in real time, but I don't hear MYSELF fine in real time: I hear myself over my headphones about half a second later; I sound like an announcer at a local baseball park. Of course, the recording itself is fine, but...it's very annoying to deal with this.

    Output device is set to Core Audio. Input device is set to the H2.

    Right now my only solution has been to just turn the monitor volume down in Audacity.

    - Hardware playthrough in the Audacity prefs does nothing. Checked or unchecked, there's no difference.
    - Software playthrough -- the "latency in audacity" search turns up a rash of hits, each saying to disable software playthrough. If I do that, then I can't hear ANYTHING.
    - The links I find all say disable software playthrough and enable the "Overdub" option. Again, I can't hear ANYTHING if I do that. (And what good is the "Overdub" option when I'm only recording one track?)
    - changing the number next to "Latency correction" has zero effect. No matter how small I make it, the delay is still there; no matter how huge I make the number, the delay is still about half a second.

    The only solution I could find was to use GarageBand instead, but even that has its own problems: my voice is chorused as I record, but reverbed when I play it back despite having no effects applied...ughhh...

    Thoughts?
     
  2. Morpheo macrumors 65816

    Morpheo

    Joined:
    Feb 26, 2014
    Location:
    Paris/Montreal
    #2
    I'm not familiar with this H2 device but does it have monitoring options? Maybe your latency problems are related to your input device and not the Mac/Audacity/etc.
     
  3. dauber thread starter macrumors regular

    dauber

    Joined:
    Jan 10, 2012
    Location:
    Chicago
    #3
    The device does have its own in-built monitoring, but then I can only hear myself...well, then again, maybe if I set the output device to the H2 (if Audacity will allow it)...that might do it...

    I considered that it might be device-related, but if it were, then GarageBand would give me latency problems, no?
     
  4. djippy macrumors newbie

    Joined:
    Apr 9, 2015
    Location:
    Montreal, Ca.
    #4
    I dont know audacity well, but within settings, there should be a tab audio with input, output and other stuff...

    The stuff you are looking for is buffer size (in samples). Put that as low as possible and it should help.

    Just found that:
    http://manual.audacityteam.org/o/man/recording_preferences.html
     
  5. Morpheo macrumors 65816

    Morpheo

    Joined:
    Feb 26, 2014
    Location:
    Paris/Montreal
    #5
    Audacity doesn't have a buffer size option. And the options listed by OP are actually from the recording tab in audacity preferences.

    @OP hardware playthrough makes no difference because you record from one device and you output to another.

    (still trying to figure out the source of your problem btw ;))
     
  6. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #6
    If you need zero latency monitoring you are going to have to use an indio interface that has that feature. You are using the Zoom outside of it's primary usage area.

    Most USB audio interfaces like say the Audiobox from Presonus have a zero latency option.

    Also some of the more sophisticated recording software will allow you to control monitoring track by track. On Apple equipment you might try looking at Garageband or Logic.
     
  7. dauber thread starter macrumors regular

    dauber

    Joined:
    Jan 10, 2012
    Location:
    Chicago
    #7
    Okay, then, if this device isn't good for zero latency monitoring, then why does it work with no latency issues in GarageBand?
     
  8. dauber thread starter macrumors regular

    dauber

    Joined:
    Jan 10, 2012
    Location:
    Chicago
    #8
    Okay, so I tried GarageBand again....heard chorus during the recording, but plain, desired raw voice in the playback. Problem solved; I'm using GarageBand for podcasting from now on. :)
     

Share This Page