Latest iTunes version that allows for jailbreaking for Mac?

Discussion in 'Jailbreaks and iOS Hacks' started by nexus14, May 11, 2010.

  1. nexus14 macrumors member

    Joined:
    May 11, 2010
    #1
    Hi there. I plan on giving my iPhone to my friend and will be going through the basic functions and how to jailbreak, etc etc.

    However, she only has a Macbook Pro and I need to know what is the latest version of iTunes that allows for jailbreaking on OS X.

    For Windows, it's version 9.03.15

    Thanks!
     
  2. tnisatard macrumors 6502

    Joined:
    Apr 1, 2008
    #2
    any version

    the latest is 9.1.1 and its okay with spiritjb
     
  3. nexus14 thread starter macrumors member

    Joined:
    May 11, 2010
    #3
    Thanks for replying!

    I forgot to mention that she also needs the carrier unlock so no Spirit JB. Only blackra1n :)
     
  4. tnisatard macrumors 6502

    Joined:
    Apr 1, 2008
  5. bytethese macrumors 68030

    bytethese

    Joined:
    Jun 20, 2007
    Location:
    Cranford, NJ
    #5
    Shouldn't you then be asking what firmware and baseband versions then and not iTunes versions? Any version of iPhone OS is jailbreakable, but only 4.26.08 is best unlockable. 05.11 is unlockable via blacksn0w, but some users report intermittent WiFi issues afterward.
     
  6. INeedAMacBook macrumors 6502

    Joined:
    Feb 8, 2010
    #6
    wondering why you said 'only using a macbook pro' whats wrong with a macbook pro :(
     
  7. Penguissimo macrumors 6502a

    Penguissimo

    Joined:
    Nov 17, 2009
    Location:
    Michigan
    #7
    If it makes you happier, read it as "a macbook pro is her only computer" ;)
     
  8. nexus14 thread starter macrumors member

    Joined:
    May 11, 2010
    #8
    Just an update for those who care to know:

    I am not worried about baseband and firmware because I already got the device jailbroken and unlocked for my OWN personal use. I did this jailbreak/unlock using Windows. It's just that I will be PASSING on the device to my friend who ONLY has a Macbook Pro that she will use for syncing/updating so I needed to know a compatible version of iTunes that would work for Mac.

    I ended up using iTunes 9.0.3 for Mac and it worked perfectly. I had to downgrade her original iTunes (it was 9.1.x) but it wasn't too bad and I managed to keep her music library intact.

    And, as stated earlier, I was limited to blackra1n and thus iPhone 3gs firmware 3.1.2 in order to maintain the T-mobile unlock.

    Thanks for everyone's help!
     

Share This Page